fixed typo by changing all references to IntegerFunction or IntegerFunctions to the plural
The typo gave an immediate error when IntegerFunctions2::Init was called instead of
IntegerFunction2::Init while the internal name of the package was integerFunction2.
The external name of the context was IntegerFunctions and everything has been changed
to match that.
The fact that this bug has existed so long leads me to believe that this context is not
much used. Is there an alternative or better way to include C(n,k) and P(n,k) as
functions in the context? I'd also suggest changing the name to something like
contextCombinatorics since I think this is more likely to show up when someone searches
for C(n,k) or P(N,k) functionality using a keyword search. This would be feasible
if the current contextIntegerFunctions has not be used very much.
-- Mike Gage and Noah Bennett