Bugzilla Reports

From WeBWorK
Revision as of 13:05, 9 July 2010 by Aubreyja (Talk | contribs)
Jump to: navigation, search
IDPStatusSeverityVersionProductSummary (4552 tasks)

Try adding


to the /webwork2/conf/snippets/hardcopyPreamble.tex file. This is required for the unionLists.pl macro file. Perhaps this could be added to the official version.

P1ASSIGNEDnormalunspecifiedWeBWorK 2Union/setAlgebraInequalities/pn1-3.pg

sub weighted_partial_grader does not work correctly with new names of answer blanks.

the line while (defined($ans_ref = $evaluated_answers{'AnSwEr'."$i"})) { needs to be replaced with while (defined($ans_ref = $evaluated_answers{'AnSwEr'.sprintf("%04d", $i)})) {

so that the new names (i.e., AnSwEr0001 instead of AnSwEr1) of answer blanks are referenced. Or, better yet, use the appropriate answer-blank-name generation macro.
P1NEWnormaldevelopPGsub weighted_partial_grader works incorrectly with new names of answer blanks


I'm unable to save any problems from the problem library to any homework sets today. In the library itself if I "add" a question it tells me that it has been successfully added but when I return to the homework sets to check they remain empty. I've never had this problem before. I've tried using IE and Chrome and am having the same problem either way.

I'd be grateful for any help.

P1NEWmajorunspecifiedWeBWorK 2Unable to save library problems to homework set

The Library Browser page, typically located at https://target.tld/webwork2/coursename/instructor/setmaker/, includes multiple parameters, such as library_subjects, library_chapters and library_sections that are not properly sanitized, leaving the application vulnerable to blind SQL injection.

Suppose the following are selected from the dropdown:

Subject: Calculus - single variable Chapter: Limits and continuity Section: Motivational applications (estimation)

The library_sections parameter can be modified to be the following:

--- SNIP ---

Content-Disposition: form-data; name="library_sections"

Motivational applications (estimation)" and substring(@@version,1,1)=5#

--- SNIP ---

If the system is running MySQL v5, the problem set will be returned; otherwise, no matching problems will be found.

I'm fairly confident earlier versions are affected as well as I ran into this on v2.5, but we upgraded before I was able to exploit it.
P1NEWcritical2.11WeBWorK 2Blind SQL Injection in Library Browser
4095 This was fixed somewhere along the line, as your example works fine in the current version of PG.
P1NEWmajor2.7PGStrict inequalities not parsed correctly without surrounding space

Fixed! From CVS log:

Changed the behavior of the exists() and delete() schema methods in all schemas (and updated the docs) s.t. not all elements of @keyparts have to be defined.

Changed WeBWorK::DB to allow undefined values to be passed instead of IDs in delete* method calls, but only if the call was made from WeBWorK::DB itself (to protect you from accidentally passing an undefined value and clobbering your whole database).

Changed delete functions to be more efficient. For example, deleteGlobalSet no longer has to say:

       $self->deleteUserSet($_, $setID)
               foreach $self->listSetUsers($setID);
       $self->deleteGlobalProblem($setID, $_)
               foreach $self->listGlobalProblems($setID);

Instead it says:

       $self->deleteUserSet(undef, $setID);
       $self->deleteGlobalProblem($setID, undef);

This is somewhat more efficient with hash-style schemas, and MUCH more

efficient with the SQL schema.
P1RESOLVEDminortrunk (SVN)WeBWorK 2Deleting a set is slow, even with SQL
67 fixed encodeAnswer to never allow the last character to be a backslash.
P1RESOLVEDcriticaltrunk (SVN)WeBWorK 2possible database corruption
      • This bug has been marked as a duplicate of 199 ***
P1RESOLVEDnormaltrunk (SVN)WeBWorK 2send mail --better error reporting needed if address is bad
  • Bug 520 has been marked as a duplicate of this bug. ***
  • P1RESOLVEDnormaltrunk (SVN)WeBWorK 2Failure to report inability to save (message feature needed)

    Links for other sets is now available. Links to other users is probably a bit long. You can go back up to the top. Maybe eventually one could add links to the statistics for the next and previous users.

    Fixed in version 1.41 of Stats.pm
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2Need sibling links for statistics pages
    171 Fixed.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2bad link in feedback

    Fixed. I changed the summary message reporting the score so that it is identical with webwork1.9.

    Now the number of correct answers is never reported, just the message "one of the answers above

    is incorrect". This works equally well with showPartialCorrectAnswers equal to 1 or to 0.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2Summary doesn't reflect the problem grader that is being used

    Moved the hints and solutions boxes so that they now appear above the submit buttons.

    That should do for now.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2show Hints is not working in this problem

    Fixed on 10/18/03

    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2refresh when editing problems-- problems with reading .tmp file
    185 This seems to be working fine now on webwork.
    P1RESOLVEDmajortrunk (SVN)WeBWorK 2scoring download works on webwork3, but not on webwork

    There is an "edit this problem" link at the bottom of the error message which allows you to fix the mistake. Perhaps the placement of this link isn't optimal, but it's not that bad. It's right at the end

    of the listing of the problem.
    P1RESOLVEDmajortrunk (SVN)WeBWorK 2saving a bad problem leaves you stranded
    191 fixed
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2exporting a set definition file -- backup file safety
        • This bug has been marked as a duplicate of 214 ***
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2problem with latex images (preview)
  • Bug 138 has been marked as a duplicate of this bug. ***
  • P1RESOLVEDnormaltrunk (SVN)WeBWorK 2warnings on bad email addresses in send mail

    Modified parseDateTime so that it handles time strings of the form 01/03/03 at 06:00am. The " at " retains compatibility with webwork 1.9 which is important for import and export. This fixes a bug introduced when changing formatDateTime. #204 and #203 should be fixed by this.

    In this file I added warning messages in distGlobalValues() which check to make sure fields are defined. Hopefyully this is not a huge time sync, but will help with debugging.

    P1RESOLVEDcriticaltrunk (SVN)WeBWorK 2Can't update time and date for individuals

    When naming the set one should not include the .def extension. I.e. the set name should be listed as mth165_2 rather than mth165_2.def.

    This error trap is correct, although perhaps we can eventually come up with a better error

    message. I'll mark this as fixed for now.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2error importing set definition:

    This has been largely accomplished with the new index.pm module (added10-12-03)

    P1RESOLVEDmajortrunk (SVN)WeBWorK 2Fix scoring front end
    242 implemented in UserList.pm.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2function to import/export users to/from CSV file on server required
    243 I think mike fixed the "to the client" part, and I don't see any reason for the "from the client" part.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2function to xfer scoring files to/from client required

    getMergedSets and getMergedProblems now call getGlobalSets/getUserSets and

    P1RESOLVEDmajortrunk (SVN)WeBWorK 2getMergedSets is slow

    was due to an inconsistency in how "gets" was being called -- it must be called with a list of array

    references IN ALL CASES.
    P1RESOLVEDmajortrunk (SVN)WeBWorK 2SQL bug?

    This has been fixed in the update to Problem.pm of 10-12-03.

    The number of incorrect attempts has to be greater than or equal to the value of $showHints in order for the show Hints button to be shown.

    There is still an opportunity for further cleanup involved in setting the want/can/will/must values for the various options. (They are set in more than one place -- perhaps the number of places where these values are modified can be

    P1RESOLVEDmajortrunk (SVN)WeBWorK 2show hints
    260 Seems to be working ok for now.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2slow access to many sets (with GDBM)
    276 mike has finished this
    P1RESOLVEDcriticaltrunk (SVN)WeBWorK 2problems with undef values from database access
    280 fixed tonight by addition of "countSetUsers" in DB.pm.
    P1RESOLVEDcriticaltrunk (SVN)WeBWorK 2instructor set list access is very slow
    285 Scoring.pm no longer hashes users by student ID.
    P1RESOLVEDmajortrunk (SVN)WeBWorK 2scoring tools not catching multiple student entries
    301 This has been fixed in Authen.pm 1.26
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2prevent login for dropped users

    I have fixed this by removing those links from the add student page.

    They didn't belong there anyway.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2links don't work

    This will have to wait until later. I have determined the following:

    PG_restricted_eval PG-answer_eval PG_macro_file_eval ( a new version of PG_restricted eval I used for testing)

    all use eval, but since they are called from within the Safe compartment the evaluations are screened for forbidden codes. It appears that you can't prepend "use strict"; to these evaluations.

    One possible solution for 5.8.0 would be to simply allow 'require' as a legal operator. That seems rather dangerous to me however.

    Only one $safe->reval($string) is used and this evaluates the problem string as well as any macros that are loaded. We don't want 'use strict;' to apply to the problems themselves, just to the macros that the problem calls.

    (sigh) Deal with this later.
    P1RESOLVEDnormaldevelopPGbe_strict fails under perl 5.8.2
    431 disabled param munging in WeBWorK.pm
    P1RESOLVEDmajortrunk (SVN)WeBWorK 2insufficient generality in handling forms?? I think.

    I fixed the problem with the virtual hierarchy in URLPath.pm revision 1.6.

    I fixed the problem with the "single set" not being retrieved properly in Hardcopy.pm revision 1.44.
    P1RESOLVEDcriticaltrunk (SVN)WeBWorK 2problem with referencing hardcopy from ProblemSet.pm
    440 This has been fixed.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2Help:: error in URLPath.pm for SetsAssignedToUser  ???
    512 added a param to pass the displayMode in the siblings links
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2sibling links don't preserve displayMode
    561 yes.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2CourseAdmin refers to "contact person" -- which field is that?
    590 too late to add this, since DB.pm is going away in 2.2 (hopefully)
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2No high level existsFoo functions in DB.pm
        • This bug has been marked as a duplicate of 556 ***
    P1RESOLVEDmajortrunk (SVN)WeBWorK 2paperSetHeader, screenSetHeader, displayMode, and ProblemSet.pm

    I've fixed this problem in Hardcopy.pm version

    on the 2-0-patches branch.

    and in version 1.48 on the HEAD

    -- Mike
    P1RESOLVEDcritical2.0.x+CVSWeBWorK 2Students can download hardcopy of hidden problems
    693 at long last, this boog is now foxed. i hope.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2string dates with no TZ are parsed in the server's TZ
    720 converted readDirectory() errors into warnings.
    P1RESOLVEDmajorunspecifiedWeBWorK 2deal gracefully with unreadable dirs in library browser

    This is fixed, but it was a weird problem. (thanks Sam for solving it.)

    The permissions for ContentManager.pm made it unavailable to the webserver. As a result a number of the commands for setting up a course couldn't be completed. The error messages said nothing at all about not being able to read the ContentManager file.

    The system now works on webwork, but we should think about how to make the warning message

    clearer if one of the modules can't be included at run time.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2HELP ! -Problems with sql_single? (only occurs on webwork.math.rochester. so far.
    756 this was done some time ago.
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2Rewrite defineEnvirVar subroutine in WebworkWebservice
    768 Fixed in ContentGenerator.pm ver 1.137 if not before.
    P1RESOLVEDminortrunk (SVN)WeBWorK 2incorrect documentation for options template escape
        • This bug has been marked as a duplicate of 769 ***
    P1RESOLVEDnormal2.1.x+CVSWeBWorK 2Maching problems broken in Internet Explorer

    This is fixed in ver 1.42 of PGanswermacros.pl and ver 1.72 of AnswerChecker.pm

    It is still true that if the answers are exactly the same as strings instead of equivalent then no warning message is given. This helps keep you from being able to guess whether the answer is correct using preview. (Warning messages don't occur

    for correct answers.)
    P1RESOLVEDnormaldevelopPGProblem in Value::cmp_compare -- no messages indicating a repeat entry show up
    896 fixed in ContentGenerator.pm 1.154
    P1RESOLVEDblockertrunk (SVN)WeBWorK 2"Previous problem", "Next problem" broken
    962 jj added this in 0.48: "Added local time zone to values which can be configured from within a course." I backported it to rel-2-3-dev
    P1RESOLVEDenhancementtrunk (SVN)WeBWorK 2Allow one to set common time zones from Course Configuration page


    • Utils.pm: add path_is_subdir
    • Problem.pm: use path_is_subdir to check sourceFilePath
                 fix logic on when to use sourceFilePath
    • ProblemSet.pm: use path_is_subdir to check sourceFilePath
                    add permissions check around sourceFilePath handler
    • ProblemSets.pm: use path_is_subdir to check sourceFilePath
    • GatewayQuiz.pm: remove code to preserve editMode/sourceFilePath (not used)

    Utils.pm (rel-2-2-dev:, MAIN: 1.73) GatewayQuiz.pm (rel-2-2-dev:, MAIN: 1.19) Problem.pm (rel-2-2-dev:, MAIN: 1.195) ProblemSet.pm (rel-2-2-dev:, MAIN: 1.79)

    ProblemSets.pm (rel-2-2-dev:, MAIN: 1.73)
    P1RESOLVEDmajortrunk (SVN)WeBWorK 2sourceFilePath parameter is insecure (or pointless... depends on the file)
    971 mike added this a little while ago
    P1RESOLVEDenhancementtrunk (SVN)WeBWorK 2define a collection of locations that can be searched for java applets

    fixed in HEAD:

    This code was badly-written to begin with -- it did work for every NONKEYFIELD in the set record, regardless of whether or not that field was to be shown in the table. As a side effect, even though ProblemSetList.pm doesn't do ANYTHING with problems_per_page, it needed to have a FIELD_PROPERTIES entry for it.

    I rearranged the code so that it determines which fields are to be shown FIRST, and then only look at only those fields.
    P1RESOLVEDmajortrunk (SVN)WeBWorK 2problems_+per_page bug

    This is too old for a bug fix to help. It's likely that problem had an infinite loop in it, but it's not a library problem and not easily available on the web.

    If this still needs fixing -- send a copy of the contents of the problem setMA108_Term1_Assignment2/MA108_T1_A2_Q2c_ComplexArithmetic.pg

    P1RESOLVEDblockerunspecifiedWeBWorKcannot access assignment 2: problem 4

    Hi Mike,

    It seems this was fixed in HEAD by Gavin last month. I'm going to to a bunch of backporting today, so I'll make sure to backport this one.

    Log Message:

    Make sure that something gets passed to renderProblems() for the userSet even when a global set is being edited and it isn't assigned to any users. Gets rid of "odd number of elements in hash assignment" errors in renderProblems. Because renderProblems plugs in a fake set if it gets a false value in for the userSet, sending in appears to solve the problem.

    Modified Files:

    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2LibraryBrowser creates unreadable sets

    the correction is made in


    in rel-2-3-dev
    P1RESOLVEDblocker2.3.x+CVSWeBWorK 2blocker error in webwork.apache-config file
    1272 recheck this, but I think this is fixed now
    P1RESOLVEDnormaltrunk (SVN)WeBWorK 2archive/unarchive and delete course

    Description of Problem: Webwork will let me log on, but when I click on the problem set it says the website can not display. It did this to me last night as well. I only have one problem left and it's due at 8 AM

    Steps to reproduce the problem: 1. 2. 3.

    Actual Results:

    Expected Results:

    How often does this happen?

    Additional Information:
    P1RESOLVEDcriticalunspecifiedWeBWorKWebwork Crash

    I have a similar problem,

    $ans1 ="($a*x+$b)**($c+1)/($c+1)"; ANS(function_cmp_up_to_constant($ans1));

    gives the "can't solve for adaptive parameters" error whenever lcd($a,$b)!=1.
    P1RESOLVEDnormalunspecifiedWeBWorK 2webwork responds "Can't solve for adaptive parameters," even though answer is correct.

    Thanks much.

    This bug is fixed as of version 1.98 of ProblemSetDetail.pm in the HEAD distribution.

    The fix is a one line change in the checkFile() subroutine at approximately line 1576.

    Let me know if this doesn't completely resolve the issue.

    -- Mike
    P1RESOLVEDmajor2.4.x + CVSWeBWorK 2Problem set detail page allows professor to view any file on the hard drive readable by apache
    1774 I believe this is now corrected in HEAD. Thanks for reporting the bug, Danny.
    P1RESOLVEDcriticaltrunk (SVN)WeBWorK 2Students can submit a Gateway Quiz after the due date if "Cap Test Time at Set Due Date" is set to yes.
    1784 hosted2 has been replaced by courses.maa.webwork.org so this bug is now moot.
    P1RESOLVEDenhancementunspecifiedWeBWorK 2Broken Links on wiki

    I think this is resolved after correcting the typo dereferencing the variable instead of using it ("$$pv" instead of "$pv"). Line 2078: change $$pv to $pv.

    P1RESOLVEDcriticaltrunk (SVN)WeBWorK 2Error in Gateway Quiz when having a problem weight greater than 1

    I believe both that the diagnosis here is correct, and that the behavior is now corrected with revision 6632 in the SVN.

    P1RESOLVEDcriticaltrunk (SVN)WeBWorK 2Answers of 0 are not recorded in the answer log in Gateway Quizzes

    Your second comment points out the issue that is actually at hand, here. The string "8.7e-5" is interpreted exactly as you say: the "e" in expressions like this is the number e, not exponential notation. (To get exponentiation, you must use a capital E.)

    The reason this is what WeBWorK expects for your answer is because of the line

          $ans = Compute("$p");

    which first forces $p to be converted to a string, and then Compute() parses is as it would any student answer to obtain the resulting MathObject. Since Perl outputs exponential notation using a lower-case e, the resulting expression does not produce the number you expect it to.

    There are two solutions:

    1. Use

       $ans = Real($p);

    rather than Compute() to convert the Perl real $p into a MathObject Real without re-parsing it, or

    2. Use

       $ans = Compute(uc($p));

    which will turn $p into a string and force it to upper case, making the "e" into an "E" that will be parsed as exponential notation.

    Your second code segment works because the eval() method returns a math object, and it converts the perl $p to a MathObject Real without re-parsing, so you get the effect of Real($p) with a lot more overhead.

    Note that when you use Compute(), the correct answer will be displayed as the string you passed to Compute() without further processing, so in your case, it would be "8.7e-5". If you want it to appear in a particular format, you would need to enter it in that format. Note that this is supposed to represent a valid answer as a student would type it, but "8.7 x 10^-5" is not such an answer. It would have to be "8.7 * 10^-5" for that.

    (I think the new output routines for the latest version of WeBWorK uses a formatted correct answer rather than a string that the student could enter, but I'm not sure how that is generated).

    P1RESOLVEDnormalunspecifiedPGAnswers between 0 and 0.0001 are marked incorrect

    I believe this was corrected in the NPL seven weeks ago. Can you check with your system administrator to update the problems on your server? If that doesn't resolve the problem please resubmit it or let me know (at <glarose@umich.edu>).


    P1RESOLVEDcriticalunspecifiedProblem LibrariesProblem will not display to some students. I can reproduce this for these students on my computer.
    2021P1RESOLVEDmajorunspecifiedWeBWorK 2errors using

    tested on test.webwork.maa.org

    appears to work properly
    P1RESOLVEDmajorunspecifiedWeBWorK 2errors using course level archive button

    fixed in gage_dev branch rev 6993

    this will merge into trunk within a month or less
    P1RESOLVEDblockertrunk (SVN)WeBWorK 2Apache2 authentication cookie must be uri_unescape 'd

    Prof. Gage -

    I finally got the chance to look at it today, and I concur with the changes you have made in lines 403 and 418. Where it was originally:

    $control = '&nbsp;';

    I replaced with:

    $control = $interactive;

    $interactive being the value which holds the CGI link. This way, the links should still show up even if no corresponding input elements are generated. I'm not exactly sure how to generate a Gateway Quiz though -- could you email me how so I can test it?

    I have svn committed my revisions, which I made on my devel server. Revision 7043.

    Was this correct?
    P1RESOLVEDblockertrunk (SVN)WeBWorK 2Link to take a gateway quiz does not show up (among others)
    2118 Forgot to change the status.
    P1RESOLVEDnormalunspecifiedProblem Librariescorrect answer not recognized

    This has been resolved by using a cron job to remove temporary files.

    See http://webwork.maa.org/wiki/Clean_Out_Temporary_Files#Using_Cron_Jobs_to_remove_temporary_files
    P1RESOLVEDcriticalunspecifiedwebwork.maa.orgStudent data shows on Google!
    2526 I don't see us fixing this in this version of the library browser, and it is fixed in the future version in webwork3.
    P1RESOLVEDcriticalunspecifiedProblem LibrariesWebserver crashes
    2806 Fixed in pull request #76 to the pg repo and pull request #228 in the webwork2 repo
    P1RESOLVEDcritical2.7PGlink to SOLUTION hidden from student's first view of problem in closed assignment
    2856 Fixed by William Boshuck
    P1RESOLVEDcriticalunspecifiedProblem LibrariesWrong answer
    3168 Fixed by William Boshuk
    P1RESOLVEDnormalunspecifiedProblem Librariesincorrect scrambling of choices in Rochester/setComplexNumbers/ur_cn_1_18.pg
    3478 There is not enough information to see if there is a bug somewhere in webwork or in a problem
    P1RESOLVEDcriticalunspecifiedWeBWorK 2[BUG] Dividing Bug

    It doesn't accept the second factor (which should be the same as the first). Thanks,

    P1RESOLVEDcriticalunspecifiedProblem LibrariesProblem has been incorrectly graded

    Same issue as the previous problem. It doesn't accept the second factor. Thanks,

    P1RESOLVEDcriticalunspecifiedProblem LibrariesProblem has been incorrectly graded

    Partially accomplished for saved files. Not yet accomplished for temporary viewing.

    Will abstract the code to Utils::copyAuxiliaryFiles(fromDir, toDir);
    P2ASSIGNEDnormal2.2.0WeBWorK 2error in finding auxiliary files when using the PG editor

    I think that adding a flag to the interface is what we want to do. While we are at it add a separate flag for SOLUTIONS since they will behave in a similar way. (Perhaps it's there already.)

    We can then decide in Hardcopy.pm when students will be allowed to printout hints and solutions. There are checkboxes on the hardcopy page for

    correct answers, hints, and solutions.
    P2ASSIGNEDnormaltrunk (SVN)WeBWorK 2hints are not printed in hardcopy
    1288 check this one in detail before declaring it resolved.
    P2ASSIGNEDnormal2.3.x+CVSWeBWorK 2Can't remove course

    rename doesn't have the capabilities that "archive course" does for automatically creating temp directories.

    unarchive a new directory (alternatively remove the html/tmp directory from the command line) try to rename it the html/tmp directory will be listed as missing but no option to add it will be given.

    work around: start to rearchive the course, then after repairing the missing directory back out and try again to rename -- it will work this time.
    P2ASSIGNEDnormalunspecifiedWeBWorK 2rename doesn't update tmp directories
    2009P2ASSIGNEDcriticaltrunk (SVN)WeBWorK 2Not working with Internet Explorer

    This is interesting.

    - The label "incorrect" comes from checking whether value for the score
     key for the answer result from the PG object returns 1 or not; here, it
     doesn't, so it (correctly) labels the result as "incorrect."
    - It looks as if the error in the "this answer is correct" labeling comes
     from comparing the number of correct parts in the answer to the number
     of answer blanks---incorrectly, of course.  The number of correct parts
     is obtained by taking $numCorrect = 0 and then incrementing with
       $numCorrect += $answerScore > 0
     (where $answerScore is the value for the PG object's score key).  This
     won't work here, as long as my memory that > associates more tightly
     than += is correct.

    I'm not sure why the > 0 test is in there. If I'm correct that we needn't test for a positive result, it looks as if the bugfix is line 368 in the file lib/WeBWorK/ContentGenerator/GatewayQuiz.pm, with the change of

      $numCorrect += $answerScore > 0;


      $numCorrect += $answerScore;

    on the other hand, if there is some reason I'm not seeing why we have to worry about the sign of the score,

      $numCorrect += $answerScore if ( $ansScore > 0 );

    might be more appropriate.

    I'll wait for anyone else to chime in (or make the patch themselves)

    before doing it in the SVN.
    P2ASSIGNEDnormalunspecifiedWeBWorK 2Gateway quiz fix -- grading errors
    2097 fixed, for now at least in revision 7053 of trunk
    P2ASSIGNEDnormalunspecifiedWeBWorK 2local problems can't be found in paths that begin local/Library ...
    2839 Students have the option to set "Show Past Answers" to yes or no. When students click on a homework question, this option appears in the left column on the bottom. Did the default value for this option change from "yes" to either "no" or nothing selected when we went to release/2.8? The default should be "yes" in order to be consistent with previous versions of webwork and with student expectations.
    P2ASSIGNEDmajor2.8WeBWorK 2submitted answers are not displayed when revisiting a page

    You can get silent errors if webwork times out (about 20 minutes) and then the webservice is called -- for example from LB1. Going to the home page triggers a login and then everything works.

    The error you see on LB1 however are small "error no data" reports from the JSON call.

    This is not horrible -- there is a work around if you understand what is happening -- but we need to provide a mechanism for the webservice to trigger a relogin after it timesout.

    This is not new -- this behavior has been around forever but it's time to fix it.
    P2ASSIGNEDnormal2.8WeBWorK 2webservice does not handle time out well

    I believe I've patched the Scoring tools error:

    pull request #748

    P2ASSIGNEDcritical2.11WeBWorK 2Directory Traversal & Arbitrary File Download
    3881 We'll make sure this is documented in release 2.13
    P2ASSIGNEDnormal2.12WeBWorK 2Can't locate object method "new" via package "Statistics::R::IO::Rserve" at line 155 of [PG]/macros/RserveClient.pl
    3917 Plan to incorporate submitted patch from Brandeis in 2.13
    P2ASSIGNEDnormal2.12WeBWorK 2debug log does not work with pipe chars

    I am using the develop branch and have

    also pulled in the multianswer_fix PR #302 and #767.
    P2ASSIGNEDmajorunspecifiedProblem Librariesbad interaction with re-randomize problem

    (In reply to comment #1) > Seems like we need to initialize course_info.txt properly?

    I noticed that Geoff Goehle recently made changes to ProblemSet.pm related course_info.txt. Could that be the reason for the issue?

    "commit d1ade51227d458296ef6b29e4b6ed99f87dcb0ae

    Author: Geoff Goehle <goehle@gmail.com>

    Date: Tue Apr 26 14:14:25 2016 -0400

       - Tweaked wording on restricted release
       - Redid default cours_info.txt file
    - Added code to hide the course_info.txt file if its the default."
    P2ASSIGNEDnormal2.12WeBWorK 2Warning in homework page after upgrading to 2.12

    I haven't yet been able to reproduce this.

    1. created homework set test_local_macros 2. Added one problem (the default blankproblem) which I renamed the path to settest_local_macros/includemacrofiles.pg 3. Added the file templates/macros/local_macros.pl

    sub _local_macros_init {}; # don't reload this file $pi_squared= Real("pi^2");

    4. the full contents of includemacrofiles.pg is below.

    includemacrofiles.pg renders correctly and the "render all" feature of the homework sets editor for the set "test_local_macros" renders without complaint.



      "PGstandard.pl",     # Standard macros for PG language
      #"source.pl",        # allows code to be displayed on certain sites.
      #"PGcourse.pl",      # Customization file for the course


    1. Print problem number and point value (weight) for the problem


    1. Show which answers are correct and which ones are incorrect

    $showPartialCorrectAnswers = 1;

    1. Setup


    $pi = Real("pi");

    1. Text

    Context()->texStrings; BEGIN_TEXT

    Enter a value for \(\pi\)


    Enter a value for \(\pi^2\)

    \{$pi->ans_rule\} END_TEXT Context()->normalStrings;

    1. Answers

    ANS($pi->with(tolerance=>.0001)->cmp); ANS($pi_squared->with(tolerance=>.0001)->cmp);

    1. relative tolerance --3.1412 is incorrect but 3.1413 is correct
    2. default tolerance is .01 or one percent.

    P2ASSIGNEDmajorunspecifiedPGHmwk Sets Editor is not detecting local macro files in 2.13

    Description of Problem:

    when creating a new user in WeBWorK from Moodle the email address of the user is not transferred from Moodle to WeBWorK. This breaks the "Email instructor" message since that message depends on the email field in the user record to tell the instructor where to send the reply.

    Steps to reproduce the problem: 1. have a new user register for a course in Moodle 2. Have them do the WeBWorK orientation assignment (this forces them to be placed in the WeBWorK user database 3. Observe the WeBWorK class list -- no email address is included in the field

    Actual Results:

    Expected Results:

    How often does this happen?

    Always in MTH142 -- I believe this happens in all cases.

    Additional Information:
    P2NEWnormalHEADwwassignmentemail record is not transferred from Moodle to WeBWorK when creating a new user

    From recent registrant:

    Thanks for setting up the account. For your amusement, the message said

    Welcome to WeBWorK! We hope you will contribute much and well. You will probably want to read the [pages].

    And when I clicked on the link, I got the error message

    Bad title

    The requested page title was invalid, empty, or an incorrectly linked inter-language or inter-wiki title. It may contain one or more characters which cannot be used in titles.
    P2NEWnormalunspecifiedwebwork.maa.orgwiki registration email provides bad link

    Document process for including geogebra applets in WeBWorK problems, based on the procedure outlined in Mike's paper given in the URL.

    See also: http://geogebraithaca.wikispaces.com/Oral+Session+1 http://geogebrawiki.wikispaces.com/Embed+GeoGebra+Worksheet https://courses.webwork.maa.org/webwork2/2010geogebra_at_ithaca/

    Ideas: Embed relevant applets into our wiki; embed live problem from above course in our wiki. Also, have look at relationship to "Problem Techniques" on applets.
    P2NEWenhancementunspecifiedDocumentationDocument inclusion of geogebra applets in WW problems.

    if there is an extra space at the end of a path -- which can occur if you paste in a path from text

    then the file will not be found.

    1. take any homework set.

    2. In the homework set editor add a space at the end of one of the paths to files

    3. save

    try to access that question -- in particular try to print a hardcopy of the homework set

    it will fail with the error that it cannot find the file
    P2NEWnormalunspecifiedWeBWorK 2trim paths in Problem set detail page

    Choose the export feature for class list.

    Export all users.

    Response is that 0 users were read into the *.lst file

    Checking the file show that the response is correct.

    Probably some simple error in grabbing the list of users.
    P2NEWmajorunspecifiedWeBWorK 2export function fails (in ghe3_dev)
    Warnings were generated during the execution of function
    1. Parameter status=!{RESOLVED,CLOSED} is invalid using regex /^[\w,@\.\s\*\/%!()+->]*$/
    follow us