Release notes for WeBWorK 2.4.0

From WeBWorK
(Difference between revisions)
Jump to: navigation, search
(New page: {{Historical}} == Introduction == The WeBWorKTeam is pleased to announce the release of WeBWorK 2.4.0. This release contains numerous improvements over WeBWorK 2.3.2. New features includ...)
 
Line 3: Line 3:
 
== Introduction ==
 
== Introduction ==
  
The WeBWorKTeam is pleased to announce the release of WeBWorK 2.4.0. This release contains numerous improvements over WeBWorK 2.3.2. New features include:
+
The WeBWorK Project is pleased to announce the release of WeBWorK 2.4.0. This release contains numerous improvements over WeBWorK 2.3.2. New features include:
  
 
:'''NewSQL:''' A new, more efficient database subsystem.
 
:'''NewSQL:''' A new, more efficient database subsystem.
Line 19: Line 19:
 
WeBWorK 2.4.0 is available from our CVS repository, or as a tarball from our SourceForge file release page. We recommend that you install from CVS. Keep in mind that because of the layout of files within the <code>webwork2</code> directory tree, upgrading an existing installation is harder using a tarball than using CVS.
 
WeBWorK 2.4.0 is available from our CVS repository, or as a tarball from our SourceForge file release page. We recommend that you install from CVS. Keep in mind that because of the layout of files within the <code>webwork2</code> directory tree, upgrading an existing installation is harder using a tarball than using CVS.
  
Installation instructions are available from InstallationManualV2pt4.
+
Installation instructions are available in the [[Installation Manual for 2.4]].
  
You must also have PGLanguageRelease2pt4pt0 installed. The installation manual also covers installing PG.
+
You must also have [[Release notes for PG 2.4.0|PG 2.4.0]] installed. The installation manual also covers installing PG.
  
 
=== Upgrading ===
 
=== Upgrading ===
  
* There are database changes in 2.4.0, so be sure to run <code>bin/wwdb_upgrade</code> [[InstallationManualV2pt4#Configuring_the_database|as described in the installation manual]].
+
* There are database changes in 2.4.0, so be sure to run <code>bin/wwdb_upgrade</code> [[Installation Manual for 2.4#Configuring_the_database|as described in the installation manual]].
  
 
== Help ==
 
== Help ==
  
If you need help installing or using WeBWorK, visit the [http://webwork.maa.org/moodle/ WeBWorK discussion group] and post your question there. The developers and many experienced WeBWorK users monitor this forum.
+
If you need help installing or using WeBWorK, visit the [http://webwork.maa.org/moodle/mod/forum/view.php?f=82 Installation forum] and post your question there. The developers and many experienced WeBWorK users monitor this forum.
  
 
== Bug Reports & Feature Requests ==
 
== Bug Reports & Feature Requests ==

Revision as of 16:26, 29 February 2008

This article has been retained as a historical document. It is not up-to-date and the formatting may be lacking. Use the information herein with caution.

Contents

Introduction

The WeBWorK Project is pleased to announce the release of WeBWorK 2.4.0. This release contains numerous improvements over WeBWorK 2.3.2. New features include:

NewSQL: A new, more efficient database subsystem.
Moodle 1.7+ compatibility: Compatibility with Moodle version 1.5 and up.
Gateway testing improvements: more flexibility about what data is shown to students and when, browser compatibility fixes, improved editing instructor-side editing of gateway test, and bug fixes.
IP restriction: It is now possible to restrict the IP from which a user can access a problem set. This is useful for gateway testing, in which students are only permitted to take the test from particular locations.
jsMath version 3.4c: See http://www.math.union.edu/~dpvc/jsmath/changes.html for list of changes.

Installation

WeBWorK 2.4.0 is available from our CVS repository, or as a tarball from our SourceForge file release page. We recommend that you install from CVS. Keep in mind that because of the layout of files within the webwork2 directory tree, upgrading an existing installation is harder using a tarball than using CVS.

Installation instructions are available in the Installation Manual for 2.4.

You must also have PG 2.4.0 installed. The installation manual also covers installing PG.

Upgrading

Help

If you need help installing or using WeBWorK, visit the Installation forum and post your question there. The developers and many experienced WeBWorK users monitor this forum.

Bug Reports & Feature Requests

Please submit bug reports and feature requests at http://bugs.webwork.rochester.edu/.

-- Main.SamHathaway - 09 Aug 2007

follow us