Upgrading the database

From WeBWorK
(Difference between revisions)
Jump to: navigation, search
(New page: Just to clarify slightly, when you upgrade to 2.3, you'll also need to run <code>wwdb_check</code> before running <code>wwdb_upgrade</code>. <code>wwdb_check</code> brings the database int...)
 
 
Line 11: Line 11:
 
* <code>[[Installation_Manual_for_2.4#Using_an_existing_database|wwdb_check]]</code> {{--}} Bring database up-to-date for version 2.3.0. Run this ''only'' when upgrading from 2.1.x or 2.2.x to 2.3.x.
 
* <code>[[Installation_Manual_for_2.4#Using_an_existing_database|wwdb_check]]</code> {{--}} Bring database up-to-date for version 2.3.0. Run this ''only'' when upgrading from 2.1.x or 2.2.x to 2.3.x.
  
* <code>[[Installation_Manual_for_2.4#Automated_database_initialization_and_upgrade|wwdb_upgrade</code> {{--}} Run this when creating a new database for 2.3.x or later, after running <code>wwdb_check</code>, or when upgrading from an earlier version in the 2.3.x or 2.4.x series.
+
* <code>[[Installation_Manual_for_2.4#Automated_database_initialization_and_upgrade|wwdb_upgrade]]</code> {{--}} Run this when creating a new database for 2.3.x or later, after running <code>wwdb_check</code>, or when upgrading from an earlier version in the 2.3.x or 2.4.x series.
  
 
[[Category:Administrators]]
 
[[Category:Administrators]]

Latest revision as of 11:32, 21 March 2008

Just to clarify slightly, when you upgrade to 2.3, you'll also need to run wwdb_check before running wwdb_upgrade. wwdb_check brings the database into a consistent state ("version 0") so that wwdb_upgrade can then do automatic upgrades. You only need to run wwdb_check when upgrading an existing database from version 2.1.x or 2.2.x to version 2.3.x. Once you've reached 2.3.x, wwdb_upgrade will be able to handle future database updates.

Ad-hoc database update scripts for 2.1.x and 2.2.x
  • wwaddindexing — Add indexes to courses originally created with the sql database layout.
  • wwdb_addgw — Add gateway testing fields to courses created with WeBWorK 2.2.x.
New upgrade scripts for 2.3.x and later
  • wwdb_check — Bring database up-to-date for version 2.3.0. Run this only when upgrading from 2.1.x or 2.2.x to 2.3.x.
  • wwdb_upgrade — Run this when creating a new database for 2.3.x or later, after running wwdb_check, or when upgrading from an earlier version in the 2.3.x or 2.4.x series.
follow us