WeBWorK Problems

Matrices with variables in the -> using operations

Re: Matrices with variables in the -> using operations

by Christopher Heckman -
Number of replies: 0
a) I tried to have WebWork calculate the transpose of a matrix, but I got the error "Can't locate object method "transpose" via package "Value::Formula"" which makes it sound as if I can't use matrix operations with variable names in them.

Bingo. Most Matrix operations require you have numbers as entries; not even fractions work. I think this is on a lot of peoples' wish lists.

b)  So I punted and just entered the transpose myself, but now when I have WebWork display the matrices so the students can enter them, the ones with variables in them don't display as a matrix, but simply as a single blank.  See attached image.

Have you tried taking out the quotation marks? Unless WeBWorK went through a major revision recently, you shouldn't need them.

c)  Is there a better way to do the 'impossible' case?

I'm going to punt on that one; I've never done essay questions before in WeBWorK.