webwork Docker install hangs at "Check in with MAA site

Re: webwork Docker install hangs at "Check in with MAA site

by Nathan Wallach -
Number of replies: 0
About a year ago the connectivity test was added to conf/webwork.apache2.4-config a modified version of which becomes /etc/apache2/conf-enabled/webwork.conf in the Docker container. 

The only way I know to disable the connectivity test for a Docker setup is to comment out the relevant line in /etc/apache2/conf-enabled/webwork.conf . That needs to done in a manner which will override the fixed version of the file already inside the Docker image (which has the "ping" line).

The best suggestion I have is to make a copy of the file from the Docker image, comment out the "ping" line, and then mount the modified file via docker-compose.yml so that when you run "docker-compose up" the modified version will be used.

Rough process:

  • cd your_webwork2_directory
  • mkdir LOCAL
  • docker-compose up -d
  • docker cp webwork2_app_1:/etc/apache2/conf-enabled/webwork.conf ./LOCAL/webwork.conf
  • docker-compose down
  • vi LOCAL/webwork.conf # or use some other editor
  • # comment out the "ping" line.
  • vi docker-compose.yml   # or use some other editor
  • # Add a line in the volume section for the webwork container with something like
  • #      - "./LOCAL/webwork.conf:/etc/apache2/conf-enabled/webwork.conf"
  • # to mount the modified file to override the existing one.
Note: I saw an explanation on how to create a "dummy container" to access a file via "docker cp" without needing to run the container. See the section on "docker create" at