WeBWorK Main Forum

No math displayed after upgrade to 2.15

Re: No math displayed after upgrade to 2.15

by Larry Riddle -
Number of replies: 0
Thanks, Danny. I ran the git command and it reported (but see below) that :
Already on 'legacy-v2'
Your branch is up-to-date with 'origin/legacy-v2'.

But here's the strange thing. I just tried checking some problems again to get ready to check the javascript console, and the math is now displayed correctly!!

I When I did the 2.15 updates several weeks ago, I followed the commands at


There is a section there about updating MathJax, so I must have run those commands. When I first tried running the git checkout legacy-v2 command tonight, I got a bunch of warnings about being unable to unlink a whole bunch of files in directory es5 with permission being denied. But at the end of the warnings it said

Branch legacy-v2 set up to track remote branch legacy-v2 from origin.
Switched to a new branch 'legacy-v2'

I then reran the git checkout using sudo, got no warnings and that was when it said we were already on legacy-v2. It was after that that I discovered that the problems were now correctly displaying the math expressions. So is it possible we actually did revert back to MathJax v.2 the first time the git command was run, even with all the warning messages?

Whatever it was that did happen, the issue now seems to hopefully be resolved. If it was indeed a MathJax issue, someone might want to revise the sentence in the Installation Manual for 2.15 that says "Updating MathJax is usually very safe".

Thanks for your help. Much appreciated.