WW 2.17 on CentOS 7 server Library Browser Error

Re: WW 2.17 on CentOS 7 server Library Browser Error

by Edwin Flórez -
Number of replies: 1


>>I don't think this is a WeBWorK bug.  Something is not working with your File::Fetch installation.

OK, I hope we can find it.

>>You can use the OPL-update-legacy script, but that will take a while (around 10 minutes if your computer is fast).

I already did it, it worked, it took about 10 minutes as you said, but the good thing is that the error is gone.


Now to solve other problems, when I ran OPL-update-legacy several errors came out, most of them are of this type that I think are from the Contrib folder that I activated::


 But the ones that most concern us for now are these, that although they are displayed well in library browser, when rendering them this error appears


In reply to Edwin Flórez

Re: WW 2.17 on CentOS 7 server Library Browser Error

by Glenn Rice -
Try changing to your home directory (for this just run "cd" from the shell), and try running download-OPL-metadata-release again (assuming that is not how you ran it before). See if that works.

I suspect that when you ran it before you were in a directory that your user does not have write permissions for. In this case File::Fetch will not be able to download the file. File::Fetch should give a warning that this is the case (it does for me), but for you File::Fetch is not showing the error for some reason.

I am not sure what is going on with OPL-update-legacy for you. I see all of the warnings when OPL-update-legacy is run (they are just warnings and not errors, and are caused by invalid tags in many of the Contrib files). However, the problems work fine in the library browser. I specifically found the problems in your screenshot, and they loaded as they should.