Forum archive 2000-2006

Mark Schmitt - Hardcopy troubles

Mark Schmitt - Hardcopy troubles

by Arnold Pizer -
Number of replies: 0
inactiveTopicHardcopy troubles topic started 5/17/2003; 10:43:48 AM
last post 5/19/2003; 10:07:14 AM
userMark Schmitt - Hardcopy troubles  blueArrow
5/17/2003; 10:43:48 AM (reads: 1200, responses: 4)
I'm experiencing a very odd problem when downloading hardcopies. For some reason, if there are images involved in the problem, the hardcopy comes out problematic. The hardcopy appears momentarily, then it disappears, leaving a mostly blank postscript file.

It appears that the images are not sized correctly and are putting whitespace around themselves, covering up much of the rest of the pages.

I downloaded the tex output and the images, and I run into the same issue when I compile on my laptop as I do if my server compiles.

This problem wasn't happening earlier in the year, and the only things I can see that may have changed are giftopnm, ppmtopgm, and pnmtops (which were all updated 2/28/03). Is there any easy way to get back to the old version, which seemed to have worked properly?


<| Post or View Comments |>

userZbigniew Fiedorowicz - Re: Hardcopy troubles  blueArrow
5/17/2003; 2:59:50 PM (reads: 1421, responses: 0)

I had a similar problem earlier this year. You need to fiddle with the following lines in system/scripts/gif2eps:


#cat $1 | $GIFTOPNM | $PPMTOPGM | $PNMTOPS -noturn 2>/dev/null > $2
cat $1 | $GIFTOPNM | $PPMTOPGM | $PNMTOPS -noturn -nosetpage 2>/dev/null > $2

# Current versions of pnmtops require the switch -nosetpage but some
# earlier versions do not accept this switch. If it causes problems
# edit it out.


<| Post or View Comments |>

userMichael Gage - Re: Hardcopy troubles  blueArrow
5/17/2003; 3:06:05 PM (reads: 1445, responses: 0)
Hi Mark,

Jason Farmer at Radison also had a similar problem (see$907 ) but there is no record of how it was resolved. If Zig's trick doesn't work, perhaps you can consult with Jason. Please post a successful resolution to the web, so that it will be quicker to resolve this issue next time.

-- Mike

<| Post or View Comments |>

userMark Schmitt - Re: Hardcopy troubles  blueArrow
5/19/2003; 8:47:44 AM (reads: 1422, responses: 0)

Thanks. That seems to have done the trick. Adding -nosetpage is the answer.

Mark (and this time I'll only submit the message once. Sorry for flooding inboxes on Saturday.)

<| Post or View Comments |>

userArnold K. Pizer - Re: Hardcopy troubles  blueArrow
5/19/2003; 10:07:14 AM (reads: 1418, responses: 0)

For further info look at$1365#1366

or more generally do a search for "nosetpage" .


<| Post or View Comments |>