Forum archive 2000-2006

Michael Gage - Migrating to WeBWorK2.0, ver 2

Michael Gage - Migrating to WeBWorK2.0, ver 2

by Arnold Pizer -
Number of replies: 0
inactiveTopicMigrating to WeBWorK2.0, ver 2 topic started 6/17/2003; 8:25:54 AM
last post 8/14/2003; 1:50:25 PM
userMichael Gage - Migrating to WeBWorK2.0, ver 2  blueArrow
6/17/2003; 8:25:54 AM (reads: 4674, responses: 4)

Instructions for migrating to WeBWorK 2.0

These instructions assume that you are already running WeBWorK 1.8, and details how to install WeBWorK 2.0 so that it runs in parallel for the same courses.

WeBWorK2 is pretty stable from the student users point of view. The tools used by the instructor are just becoming useable and are still somewhat unstable. For the next month we'll ask that anyone wishing to try out WeBWorK 2.0 obtain the scripts via a CVS (as per the instructions in this document) so that they can easily update to obtain the latest bug fixes as they are made.

A second step in the migration (not yet described in detail) will allow you to use a mysql database instead of the GDBM database currently in use. Using the mysql database will increase the options available for the instructor, as well as the speed on large data sets.

In order to use WeBWorK 2.0 you MUST have mod_perl enabled on your apache server. (If you don't know what this means, then wait a bit before trying out WeBWorK 2.0)

I'll assume three things:

  1. your current webwork 1.8 system has the structure .../topDir/webwork/system/.... and that system directory has sub directories such as cgi, courses,courseScripts, scripts, and so forth.
  2. Similarly your course will be contained in a structure ../courses/myCourse/... and the myCourse directory will contain, html, templates, and so forth. The templates directory will contain a macros directory (which will probably be empty). (In many cases, following the standard setup for WeBWorK1.8, the course directory will be at ../topDir/webwork/courses/myCourse, that is the courses and sytem directory are siblings.
  3. Finally the links to your courses are of the form http:\//myMachine/myCourse/. For example you might have a directory called ../htdocs/ which is the home directory for your apache server and which contains links to the html directory of myCourse:
    ls -l
    myCourse ---> ...../courses/myCourse/html/

Here we go.

First we create the directories linked to the cvs repository. (Full details are at

Set up ssh key file(see details at ) -- this seems to be the step that often causes difficulties. See subsequent posts below for troubleshooting.

We want to create the file ~/.ssh/webwork-anoncvs containing (approximately) the following text

MIIBuwIBAAKBgQD7Bhq+4va4riYRUzOeYIUoi8KT7648N955rYWOjnWHd45ah5+V sCORY77sciOT+P06GseZR/KuaVfQr8pEN7SboTAkYrpWh6bgstp1IDjdmkdKBVc5 7S/nL6MQBaeLGt2FcyaTl7w+S8VJqkBVwgS/4cK7Zd4DCPJnSW840JKROwIVAJRE tz/9+35Nx7FPC7hOjfbs6u+bAoGBAO0nfXXO8/HZk5dgE/LE4LXU8tWBJD6OJ6XY sEGnsP7XQTiBnTWEiNyoaJ+7BC+yf7ytGTiehQNmv4YWs/hAFNhqwHqXJp8sdJsy tROouNbLbbnem4mDZWtckjk6oYUurX/qILNTmmSz6hAz73ArzpnI09aUKYMInUH+ D50QO5FJAoGATDc97ufm/gYey730D+PXsccF3+fCXvOQ192T0QyoCMX735oKoOXm pZwD4TojJlnsF7fm8JatCTm6kv8fGCT/xELo0RG9xt/RTzA+HGsF8qwXEcsZO9sS KEFnQ0+RmLT4J5oV8FJex6itcacNlzsK7cSUXC+N46ztH4oW6L+3zVACFCu+c/M/ +V0SY1WLIBqGR/loTnvp


Making sure that the contents of this file are exactly correct seems to be difficult when copying the text from the screen. Instead use option-click (or alt-click or control-click -- whatever works in your browser) to copy the key file directly to your desktop or download directory. The url for the key file is . Move or copy the downloaded file to ~/.ssh/webwork-anoncvs (no extension) and make sure that the permissions are set correctly as below.

Set the permissions for this file webwork-anoncvs to 600 or it will not work. Secret keys are not supposed to be generally readable!

Add these lines to the ~/.ssh/config file . You may have to create it.

User anoncvs
IdentityFile ~/.ssh/webwork-anoncvs
ForwardAgent no
ForwardX11 no
Compression yes

Set the environment variable CVS_RSH to ssh . In bash, type export CVS_RSH=ssh . In tcsh, type setenv CVS_RSH ssh . Since you need this variable set whenever you want to use the webwork CVS repositories, you might want to add it to your .bashrc, .profile or .cshrc file (depending on your shell).

  1. cd topDir/webwork # (get to your webwork directory)
  2. In order to install the webwork-modperl scripts you will need write permissions in this directory.
  3. The address of the CVS repository has changed! It's now on
  4. cvs -d checkout webwork-modperl
  5. This will create a directory webwork-modperl inside topDir/webwork
  6. Next we create a directory for pg
  7. cvs -d checkout pg

Make sure that these files can be read by the apache daemon

The directories have 744 permissions when they are created. We need to make sure that the directories can all be executed by the apache daemon and read by it as well.

  1. While still in topDir/webwork type:
    1. chmod -R go+X webwork-modperl
    2. chmod -R go+X pg
    3. This adds execution permissions to all of the directories in the webwork-modperl tree and the pg tree, allowing access to the files in the webwork-modperl directories. The capitalization is important (as is usual in unix commands).
    4. We are using relatively lax security, since anyone can now read these files. ("Tightening the permission structure" -- to be written)
  2. To determine the groups which your apache server belongs to type
    ps -aux |grep httpd

    to get a listing of processes which are running. Look for something like  
    wwhttpd 72270 0.0 0.1 1896 1384 ?? I 1:00AM 0:00.01 /usr/local/sbin/httpd
    wwhttpd 72274 0.0 0.1 1908 1392 ?? S 1:02AM 0:00.04 /usr/local/sbin/httpd

    This tells me that the apache daemon is named wwhttpd on our machine
    Next type
    groups wwhttpd
    webwork MTH161 MTH141A MTH140A MTH140L MTH141 MTH142 MTH143 ....

    Our daemon belongs to many course groups and also to one general group webwork. For WeBWorK 2.0 the daemon only needs to belong to one group -- in our case webwork
    You may need to consult with whomever has been setting up groups for your WeBWorK 1.8 course.
  3. From the topDir/webwork directory set the group for the directory webwork-modperl to webwork
    1. chgrp -R webwork webwork-modperl
      ls -l
      drwxr-xr-x 14 gage webwork 512 May 31 12:33 webwork-modperl/
      chgrp -R webwork pg
  4. Set write permission for the logs directory
    1. % cd webwork-modperl
      % ls -l
      total 24
      drwxr-xr-x 2 gage webwork 512 May 31 12:33 CVS/
      drwxr-xr-x 3 gage webwork 512 May 31 12:33 bin/
      drwxr-xr-x 3 gage webwork 512 May 31 12:33 conf/
      drwxr-xr-x 4 gage webwork 512 May 31 12:33 courses/
      drwxr-xr-x 3 gage webwork 512 May 31 12:33 doc/
      drwxr-xr-x 4 gage webwork 512 May 31 12:33 htdocs/
      drwxr-xr-x 5 gage webwork 512 May 31 12:33 lib/
      drwxr-xr-x 3 gage webwork 512 May 31 12:33 logs/
      drwxr-xr-x 4 gage webwork 512 May 31 12:33 tests/
      drwxr-xr-x 3 gage webwork 512 May 31 12:33 tmp/
    2. % chmod g+w logs # make the directory writeable for the group webwork
    3. % ls -l # check that it worked!
      drwxrwxr-x 3 gage webwork 512 May 31 12:33 logs/

Configure WeBWorK 2.0

-- to make sure that it knows where to find files and databases. This is done in the configuration (conf) directory.

  1. % cd conf
  2. Make local copies of the global.conf.dist, gdbm.conf.dist and sql.conf.dist files.
    1. cp global.conf.dist global.conf
      cp gdbm.conf.dist gdbm.conf
      cp sql.conf.dist sql.conf
      nano global.conf (# or pico global.conf might work, or use emacs or vi :-) )
    2. The variable $webworkRoot will point to the directory topDir/webwork/webwork-modperl which you have created. You should not need to change any of these values when using the default configuration. If you change the directory structure of WeBWorK for some reason you may also have to make changes here.
  3. Initially you will only need to make one change (if your directory structure is as described in the instructions above).
    1. Change addresses for oldProf in the structure
    2. %webworkURLs = ( root => "$webworkURLRoot", home => "/webwork2_files/index.html", htdocs => "/webwork_files", docs => "", oldProf => "/webwork-old/", );
    3. to
    4. %webworkURLs = ( root => "$webworkURLRoot", home => "/webwork2_files/index.html", htdocs => "/webwork2_files", docs => "", oldProf => "", );
    5. The oldProf url should just like the url that WeBWorK 1.8 uses on your system when you go to the "professor Page" to edit classlists, butild sets and so forth.
    6. The structure for the external programs used by webwork may also need adjusting
      %externalPrograms = (
      mkdir => "/bin/mkdir",
      tth => "/usr/local/bin/tth",
      pdflatex => "/usr/local/bin/pdflatex",
      latex => "/usr/local/bin/latex",
      dvipng => "/usr/local/bin/dvipng -mode ljfivemp -D600 -Q6 -x1000.5 -bgTransparent",
      gif2eps => "$webworkDirs{bin}/gif2eps",
      png2eps => "$webworkDirs{bin}/png2eps",
      gif2png => "$webworkDirs{bin}/gif2png",
    7. You can insure that the external programs have been installed on your machine by typing
      1.   which tth /usr/local/bin/tth which pdflatex /usr/local/bin/pdflatex which dvipng /usr/local/bin/dvipng

Configure the Apache server

Now we have to tell the apache server where to find the webwork 2.0 files. It helps to have someone who has set up and restarted the apache server help out at this point.

  1. First find the apache config file. Usually called httpd.conf and found perhaps in /etc/httpd/ or in our case /usr/local/etc/apache
  2. Check that httpd.conf contains these two lines (uncommented). The lines are in two different sections of http.conf
  3. LoadModule perl_module libexec/httpd/
    AddModule mod_perl.c
  4. If these lines are there, but commented out with a #, just uncomment them. If they are not there at all then you first need to build an apache daemon which will run mod_perl. That is beyond the scope of this note.
  5. Assuming that all is well, we need to add these two code fragments to the httpd.conf file. (These directions are also available on the page how to use CVS with WeBWorK2.) You will see similar code fragments in the file already.
  6. The fragments you need are in the file conf/httpd.conf.INSERTME but you will need to edit them first. You can edit a copy of that file and then cut and paste the contents into http.conf.
  7. The WEBWORK_DIR should be replaced by ...topDir/webwork as described above.
    <IfModule mod_perl.c>
    PerlFreshRestart On
    <Location /webwork2>
    SetHandler perl-script
    PerlModule Apache::DProf
    PerlHandler Apache::WeBWorK
    PerlSetVar webwork_root WEBWORK_DIR/webwork-modperl
    PerlSetVar pg_root /WEBWORK_DIR/pg
    use lib 'WEBWORK_DIR/webwork-modperl/lib';
    use lib 'WEBWORK_DIR/pg/lib';
  9. We also need to define url link for the accessing images and such like.
    # This DocumentRoot doesn't actually make a lot of sense. In a
    # WeBWorK mod_perl system, there is no static document root, but the
    # DocumentRoot does have to exist, and not have a subdirectory
    # named WeBWorK. It suffices.
    DocumentRoot "WEBWORK_DIR/webwork-modperl/htdocs"
    # This alias, however, is important.
    Alias /webwork2_files/ /WEBWORK_DIR/webwork-modperl/htdocs/
    # This should match the DocumentRoot
    <Directory "/WEBWORK_DIR/webwork-modperl/htdocs">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
  11. The alias allows you to find installation wide information stored in the webwork-modperl/htdocs directory. This includes the index.html file and courses which contains links to the html directories of each of your courses.
  12. Finally here is a little test module that will help with trouble shooting which is worth installing.
    # status test
    <Location /ww_status>
    SetHandler perl-script
    PerlHandler Apache::Status

Restart the Apache server

Before doing this locate the location of the apache error log.

You can search httpd.conf for ErrorLog. Our error log is stored at /ww/logs/error_log on one machine and /var/log/error_log on another.

In a separate window issue the command


tail -f /ww/logs/error_log

(use your own path to the error log) to view the last 20 lines or so of errors issued by the apache server.

The restart command is called apachectl (apache control) and is probably in /usr/local/sbin You need super user privileges to start and stop the server, hence the use of the sudo command.

Tell the apache server to shutdown and restart gracefully.

sudo /usr/local/sbin/apachectl graceful

You can also use the commands apachectl start and apachectl stop

In the window showing the contents of the error_log you should see a flurry of activity. The last messages should not be error messages. If they are, try to decipher them. They might indicate a typo in http.conf which you have to correct.

Another possibility is that one or more perl modules have not been installed. ( is the most likely culprit). These modules are all common perl modules and can be obtained and installed from CPAN. ("Instructions on installing CPAN modules" to be written.)

Refer to the error log listing whenever something funny happens. There may be a useful error message.

Testing the server

Open a browser go the url If this works it should give a number of links to information about your apache server, including which modules are installed. This means that mod_perl is working. Your version of perl should be at least 5.6 in order to insure compatibility with WeBWorK2.0.

Next type the url This should give a response of Welcome to WeBWorK2.0 at the University of Rochester

For the fun of it go to topDirs/webwork/webwork-modperl/htdocs and edit the file index.html, replacing the University of Rochester by your own institution. This is just an html file, you can add anything else you want. Test that it works. You don't have to restart the server.

Now type This should redirect you to the file above. If this works then the locations pointed to by the entries in the http.conf file are correct.

Here is a review of the connections which have been made in the http.conf file
<Location /webwork2>
Tells us that webwork URL for all dynamic actions is
PerlSetVar webwork_root WEBWORK_DIR/webwork-modperl
Tells perl the path to your webwork-modperl directory, which contains the bulk of the WeBWorK2 files
PerlSetVar pg_root /WEBWORK_DIR/pg
Tells perl the path to your pg directory, which contains the macros and .pm files which define the .pg language for writing problems in WeBWorK1.8 and WeBWorK2.0
use lib 'WEBWORK_DIR/webwork-modperl/lib';
Insures that perl looks for files in the webwork-modperl library tree
use lib 'WEBWORK_DIR/pg/lib';
Insures that perl also looks for files in the pg library tree
Alias /webwork2_files/ /WEBWORK_DIR/webwork-modperl/htdocs/
Tells us that the address for static files the webwork htdocs directory are reached with the url
The fragment containing the directory defines the permissions which decide who is allowed to see these files.

Trouble shooting

Keep the window to the error log open and check it often

Otherwise mysterious errors print relatively helpful messages to the error log.

Missing modules

You will probably be missing some perl modules that are used by WeBWorK. The error message in the error log file will tell you which modules cannot be found. The modules are all available on CPAN. Three modules which are likely to be missing are Time::HiRes Mail::Sender and MIME::Base64

On many systems you can install these with


sudo perl -MCPAN -e shell

cpan> install Time::Res


Hooking up to your current WeBWork 1.8 course

We now know that WeBWorK2.0 system is working and connected. It remains to connect WeBWorK2.0 to the WeBWorK1.8 courses which you already have set up.

There are two connection points to WeBWorK2.0

  1. A URL of the form will access myCourse if it is in the directory topDir/webwork/webwork-modperl/courses/myCourse In fact that directory already contains a minimal course called test_course so should give you a login page. (If you enter a login name you will get an error, because no database of users has been built for this course yet. Just getting the login message is enough to confirm that this link is correctly set up.)
  2. The second link is for URLs of the form which will access the links in topDir/webwork/webwork-modperl/htdocs/courses. The htdocs/courses directory contains symlinks to the html directory in each course. In our case
    1. ls -l htdocs/courses
    2. should give
    3. test_course --> topDir/webwork/webwork-modperl/courses/test_course/html

Notice that the first directory, topDir/webwork/webwork-modperl/courses corresponds to the directory ../courses mentioned as the second of the three assumptions I made at the top of this page. It is the directory that contains all of your WeBWorK1.8 courses. We will make a symlink between the two directories. While in the directory webwork-modperl type

mv courses
ln -s .../courses courses

We moved the webwork-modperl/courses directory out of the way (saving it) so that we could construct a symlink between the webwork-modperl/courses link (alias) and the .../courses directory containing the WeBWorK 1.8 courses. The "test_course" URL will no longer work, since it is now in instead of in courses.

Next transfer to webwork_modperl/htdocs (cd htdocs)

mv courses
ln -s ..../htdocs courses

We have symlinked the topDir/webwork/webwork-modperl/htdocs/courses directory to the .../htdocs in your WeBWorK1.8 setup.

The .../htdocs directory itself contains a link to .../courses/myCourse/html

Testing the hook-up

Type the url (making the obvious substitutions for your server and your course)

You should get the login page for your existing WeBWorK1.8 course! If you don't, then there might be a problem with the symlink between the directory ..topDir/webwork/webwork-modperl/htdocs/courses and the .../htdocs directory. Check also that the .../htdocs directory has a symlink called myCourse which points to .../courses/myCourse/html. It is a common mistake to forget the last html in the link.

The other connection that might be at fault is the Alias entry in http.conf (Alias /webwork2_files/ ...topDir/webwork/webwork-modperl/htdocs/ )

Assuming all is well so far type the url where myCourse is the name of one of your existing courses. You should get a login screen and be able to view your course. If this doesn't work at all, check the <Location /webwork2> directive in the httpd.conf file. Check also the permissions on the files and directories in webwork-modperl. Remember that the apache server must be able to execute the directories in order to read the files inside.

If you get an error screen saying something like: "Can't read .../macros/" then either the PerlSetVar pg_root topDir/webwork/pg is not pointing to the topDir/webwork/pg directory or the server does not have permission to read the files in that directory (Again remember that it must be able to execute the directories in order to read the files inside.)

The access to the professor pages is still being developed. When you click on the "instructor" link in the left maargin you will be taken to a page where you can use the "professor pages" from WeBWorK 1.8 to edit your course (the third and fourth links) or you can use the second link to edit problem sets. The first link, to edit users is not yet very functional. If the third and fourth links don't work check the value given to oldProf in the global.conf file.

You can report bugs using the bug link in the upper left corner. The first time you do this you will need to login and receive a password via e-mail. Once logged in bugzilla will set a cookie and you will be taken directly to the page for reporting bugs.

Speeding up large classes.

You don't HAVE to make any configuration changes in your course directory. However one change will speed up the listing of problem sets in large courses:

Inside your course myCourse (this directory contains, templates, DATA, etc.) create a file course.conf

Inside course.conf place the lines

$dbLayout{set}->{params}->{globalUserID} = "yourID";

# yourID is the instructor's loginID for the course (or whoever is responsible for building sets and maintaing the course.)

$dbLayout{problem}->{params}->{globalUserID} = "yourID";

There are other customization which can be made in this file to override those in global.conf, but we'll come to those later.

Test results on my site:

After restarting the server:
This gives me output starting with Embedded Perl version v5.6.1 for Apache/1.3.27 (Unix) mod_perl/1.27 process 91936 , running since Mon Jun 16 13:48:52 2003 and followed by several links.
This assures me that mod_perl is working and reading the httpd.conf file that I just modified.
This should return Welcome to WeBWorK at the University of Rochester which is the contents of the file WEBWORK_ROOT/htdocs/index.html . This indicates that the link to WEBWORK_ROOT/htdocs is set up properly.
You can modify this file to name your institution and add anything else you like.
This should be redirected to the address at webwork2_files above and will give the same output. This indicates that the dispatcher for WeBWorK2 is working.
mth143 is a course in the /shared-courses/ directory. (This location for courses was specified in global.conf.)

I get a login page for the course.

Sample errors on my site:

Can't open file /home/gage/webwork/pg/macros/ for reading Can't open file /home/gage/webwork/pg/macros/ for reading Can't open file /home/gage/webwork/pg/macros/ for reading
I had forgotten to check out the pg directory! It's also possible that the permissions on the pg directories and subdirectories don't allow the server to access the files. Check (1) that the pg directory exists (2) that the permissions are reasonable for the server. and (3) That the address of PG_ROOT in the httpd.conf file is pointing to the pg directory.

Post comments in reply to this note -- let me know what worked and what didn't.

Troubleshooting responses to test: ssh$1705

Trouble shooting responses to test: cvs -d checkout webwork$1706

-- Mike Gage

<| Post or View Comments |>

userMichael Gage - Re: Migrating to WeBWorK2.0, ver 2  blueArrow
8/13/2003; 10:48:52 AM (reads: 5791, responses: 0)
FAQ: Setting the ssh key

Test: ssh

Response 1: [cartan:~] gage% ssh

Problem 1: The file .ssh/config has not been properly set up. Did you enter the 6 lines which describe the host, the user and the IdentityFile? There should be no spaces between the 6 lines.

Can the config file be read?

Response 2:

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @ WARNING: UNPROTECTED PRIVATE KEY FILE! @ @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ Permissions 0644 for '/Users/gage/.ssh/webwork-anoncvs' are too open. It is recommended that your private key files are NOT accessible by others. This private key will be ignored. bad permissions: ignore key: /Users/gage/.ssh/webwork-anoncvs Enter passphrase for key '/Users/gage/.ssh/webwork-anoncvs':

Problem: The config file is probably ok, but the file containing the ssh key (.ssh/webwork-anoncvs) has not been configured correctly. It should have permissions 600. Use chmod 600 webwork-anoncvs (issued from the .ssh directory) to fix the permissions.

Response 3: Enter passphrase for key '/Users/gage/.ssh/webwork-anoncvs':

Problem: This looks like the ssh key is set up correctly. It will not let you login directly, but it should let you use CVS to download files.

<| Post or View Comments |>

userMichael Gage - Re: Migrating to WeBWorK2.0, ver 2  blueArrow
8/13/2003; 11:01:27 AM (reads: 5694, responses: 0)
cvs -d checkout webwork

Response: Connection refused

Assuming that you have the ssh key working properly (see post above) I'll bet you forgot to set CVS_RSH to ssh. Type

setenv CVS_RSH ssh

(when using tcsh or csh shell. See directions for bash shells.)

You should add this line to your .profile or .cshrc files so that you don't have to reset this environmental variable by hand every time.

Now try the test again.


[cartan:~/webwork] gage% cvs checkout pg
Enter passphrase for key '/Users/gage/.ssh/webwork-anoncvs':


This seems to happen if the key in .ssh/webwork-anoncvs is not exactly right. Try downloading the key file directly from (option click, or control click will let you save the file directly to disk from many browsers). Move the saved file to .ssh/webwork-anoncvs (no extension). Make sure the permissions are 600. Now try again.

<| Post or View Comments |>

userMark Schmitt - Re: Migrating to WeBWorK2.0, ver 2  blueArrow
8/14/2003; 1:11:29 PM (reads: 5256, responses: 0)
I decided to take the plunge and install WeBWorK 2.0 Since I had Apache 2.0 running WeBWorK 1.8, I decided to install a clean version of Apache with mod_perl imbedded. I followed the directions at

I also followed Mike's directions in this note. I ran into some success and some problems.

ww_status works fine, and returns the following: Embedded Perl version v5.8.0 for Apache/1.3.28 (Unix) mod_perl/1.28 process 2552, running since Thu Aug 14 10:28:33 2003

webwork2_files works properly.

webwork2/ does not work properly. A sample from the error log is at the bottom of this message. The short form of the problem is that the system is unable to find Apache/ I have a copy of that file, but if I move it into a directory in @INC, I end up missing DATE/

I used mod_perl-1.28 and apache_1.3.28. Any ideas as to how I can find and install the missing pieces in a useful way would be appreciated.


[Thu Aug 14 12:26:44 2003] [notice] SIGHUP received. Attempting to restart [Thu Aug 14 12:26:44 2003] [notice] Apache/1.3.28 (Unix) mod_perl/1.28 configured -- resuming normal operations [Thu Aug 14 12:26:44 2003] [notice] Accept mutex: sysvsem (Default: sysvsem) [Thu Aug 14 12:27:02 2003] [error] Can't locate Apache/ in @INC (@INC contains: /usr/lib/perl5/vendor_perl/5.8.0/HTTP /usr/local/webwork/pg/lib /usr/local/webwork/webwork-modperl/lib /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl . /home/httpd/ /home/httpd/lib/perl) at /usr/local/webwork/webwork-modperl/lib/ line 17. BEGIN failed--compilation aborted at /usr/local/webwork/webwork-modperl/lib/ line 17. Compilation failed in require at /usr/local/webwork/webwork-modperl/lib/Apache/ line 39. BEGIN failed--compilation aborted at /usr/local/webwork/webwork-modperl/lib/Apache/ line 39. Compilation failed in require at (eval 59) line 3.

[Thu Aug 14 12:27:02 2003] [error] Undefined subroutine &Apache::WeBWorK::handler called.

<| Post or View Comments |>

userMichael Gage - Re: Migrating to WeBWorK2.0, ver 2  blueArrow
8/14/2003; 1:50:25 PM (reads: 5124, responses: 0)

Just out of curiosity are you using perl 5.8.0? We have 5.6.1 one here, so I haven't tried it yet.

On our site, the Apache request module is located at /usr/local/lib/perl5/site_perl/5.6.1/mach/Apache/

I also have a module:

/usr/local/lib/perl5/site_perl/5.6.1/Date/ (I assume you meant Date::Format not DATE::Format).

If these modules are not present they can be found on CPAN.

I typically use

perl -MCPAN -e shell

in order to install modules from CPAN. Once it's set up it's pretty efficient most of the time.

Sounds like you have made good progress on the installation. I think you just need to add these modules (and perhaps a few more) in order to get it running.


<| Post or View Comments |>