Forum archive 2000-2006

bpollina@c... - Porting courses to new server

bpollina@c... - Porting courses to new server

by Arnold Pizer -
Number of replies: 0
inactiveTopicPorting courses to new server topic started 8/1/2003; 4:43:27 PM
last post 8/2/2003; 11:34:34 AM
userbpollina@c... - Porting courses to new server  blueArrow
8/1/2003; 4:43:27 PM (reads: 984, responses: 2)
We just finished installing WeBWorK 1.9 on a brand new server running RedHat9.0. The installation went smoothly and we successfully installed the new demoCourse. All features worked beautifully including typeset2. We were also able to create several new courses without a hitch.

We then tried to move existing courses over to the new server. We moved files to the appropriate directories, ran course_webwork_setup and set up the needed symbolic links. We did not run the import classlist script assuming this was not necessary because the database files already existed, and we wanted to preserve them. We were unable to login receiving the following error:

Error: Key database error Can't tie /var/www/webwork/system/courses/M144Pollina/DATA/.auth/M144Pollina_password_DB: No such file or directory

However, these files do exist and seem to have the correct ownership and permissions.

Any help would be appreciated.

Ben Pollina University of Hartford

<| Post or View Comments |>

userArnold K. Pizer - Re: Porting courses to new server  blueArrow
8/1/2003; 8:55:20 PM (reads: 1238, responses: 0)
Hi Ben,

First note that the GDBM binaries are OS dependent. If your old server was running Solaris, then you can not just transfer the binary databases to a new server running Linux.

In this case if you want to transfer existing databases, use the shell scripts:

Then transfer the resulting ascii files and then run:

Don't transfer the keys database. It will be recreated.

Hope this was your problem.


<| Post or View Comments |>

userbpollina@c... - Re: Porting courses to new server  blueArrow
8/2/2003; 11:34:34 AM (reads: 1231, responses: 0)

Thanks. I'll give this a try. I did just try to copy the files directly.


<| Post or View Comments |>