Forum archive 2000-2006

Lars Jensen - Permission problem - Webwork2

Lars Jensen - Permission problem - Webwork2

by Arnold Pizer -
Number of replies: 0
inactiveTopicPermission problem - Webwork2 topic started 5/26/2004; 3:08:46 AM
last post 5/27/2004; 3:00:25 AM
userLars Jensen - Permission problem - Webwork2  blueArrow
5/26/2004; 3:08:46 AM (reads: 898, responses: 2)
When installing webwork2 on our production server, I get the following message when trying to access the /webwork2 page:

Forbidden - You don't have permission to access /webwork2 on this server.

The /webwork2_files displays fine.

I get the same Forbidden message when trying to access the  http://server/server-info page (I did make sure that the apache mod_info module is installed, and I uncommented the corresponding  lines in httpd.conf).

The forbidden messages puzzles me because I have no problem displaying the server-info page on two other servers similar to the production server.

My assumption is that it is the same issue that prevents viewing the /server-info page and the /webwork2 page. Any ideas what the permissions on /server-info being referred to above might be?


<| Post or View Comments |>

userJohn Jones - Re: Permission problem - Webwork2  blueArrow
5/27/2004; 12:21:43 AM (reads: 1071, responses: 0)
Hi Lars,

I wouldn't worry much about the server-info page.  It never works for me and doesn't seem to be worth configuring.  I think you can get similar information from /path/to/httpd -l.

The two basic things to check are actual permissions on the directories themselves, and the apache configuration files.  If you have webwork 2 working on another machine, you could diff the conf files to look for differences.


<| Post or View Comments |>

userLars Jensen - Re: Permission problem - Webwork2  blueArrow
5/27/2004; 3:00:25 AM (reads: 1088, responses: 0)
Hi John,

Thanks for responding. The reason I wanted to sort out the /server-info page issues is that I suspected that the problem with this page was the same as those with the /webwork2 page. This turned out to be the case: The problem with both pages went away when I turned off MultiViews for the apache documentroot directory.


<| Post or View Comments |>