Forum archive 2000-2006

Frank Wolfs - runtime_use error

Frank Wolfs - runtime_use error

by Arnold Pizer -
Number of replies: 0
inactiveTopicruntime_use error topic started 8/11/2004; 1:22:11 PM
last post 8/15/2004; 9:54:53 PM
userFrank Wolfs - runtime_use error  blueArrow
8/11/2004; 1:22:11 PM (reads: 960, responses: 2)
I upgraded to webwork 2 during the last two weeks, and I amg going through my old courses to ensure that they are still "viewable" under webwork 2 (since up to now I only used webwork 1). I did not have problems with most of my courses (and after adding course.conf they worked fine) but for two of my courses I am stuck. When I try to look at problems, I get the following error in the log file when I try to view the problems in the set and/or make hardcopies.

uncaught exception in Apache::WeBWorK::handler: runtime_use: no module specified at /home/webwork/webwork2/lib/WeBWorK/ line 48

The set works find under webwork 1. I look at line 48, in, but it looks like Chinese to me.

<| Post or View Comments |>

userMichael Gage - Re: runtime_use error  blueArrow
8/15/2004; 9:54:18 PM (reads: 1175, responses: 0)
Hi Frank,

Here's the offending lines:

sub new {
shift; # throw away invocant -- we don't need it
my ($ce, $user, $key, $set, $problem, $psvn, $formFields,
$translationOptions) = @_;

my $renderer = $ce->{pg}->{renderer};

line 48: runtime_use $renderer;

return $renderer->new(@_);

It appears that $renderer is not being defined. or possibly even worse that $ce is not being defined.

The $ce->{pg}->{renderer} is defined in global.conf and then over ridden in course.conf

As a start, rename course.conf in each of the courses that is giving you trouble. If things work then, you know there is something wrong with the entries in course.conf that is causing the trouble. Something that is undefining pg->{renderer}

Hope this helps.

Take care,


<| Post or View Comments |>

userMichael Gage - Re: runtime_use error  blueArrow
8/15/2004; 9:54:53 PM (reads: 1162, responses: 0)
OK, Frank. Glad that solved the problem.

<| Post or View Comments |>