Forum archive 2000-2006

Blake Thornton - AliasMatch

Blake Thornton - AliasMatch

by Arnold Pizer -
Number of replies: 0
inactiveTopicAliasMatch topic started 8/20/2004; 6:27:11 PM
last post 8/23/2004; 3:13:13 PM
userBlake Thornton - AliasMatch  blueArrow
8/20/2004; 6:27:11 PM (reads: 943, responses: 2)
I am still unable to generate a hardcopy of problem sets. Okay, actually, the hardcopy is generated, but the problem lies in the AliasMatch command in webwork.apache-config.

I know this has come up before, specifically in:$2455

Right now, we have the line:

AliasMatch $webwork_courses_url/([^/]*)/(.*) $webwork_courses_dir/$1/html/$2

Which, from what I can tell, is correct. But, I am getting funny errors similar to what was in the previous posting on this topic:

[Fri Aug 20 17:21:29 2004] [error] [client] File does not exist: /opt/webwork2/courses//html/

I have tried playing with the AliasMatch command, it is seems the backreferences are just not working correctly. For example, if I change the config file to:

AliasMatch $webwork_courses_url/([^/]*)/(.*) $webwork_courses_dir/Testing/html/tmp/hardcopy/Testing.admin.set4.pdf

then everything works alright (except of course this is the only file that will be delivered!).

If I change it to:

AliasMatch $webwork_courses_url/(Testing)/(.*) $webwork_courses_dir/$1/html/tmp/hardcopy/Testing.admin.set4.pdf

(Note: there is a slash before the $1, but I don't know why it isn't being displayed. In any case, I have tried it with and without the slashes in just about every combination conceivable.)

[Fri Aug 20 17:24:33 2004] [error] [client] File does not exist: /opt/webwork2/courses//html/tmp/hardcopy/Testing.admin.set4.pdf

If I look in the server access log, I get something funny too: - - [20/Aug/2004:17:24:33 -0500] "GET /webwork2_course_files/Testing/tmp/hardcopy/Testing.admin.set4.pdf HTTP/1.1" 404 345

In other words, it looks like in the server error log, it is missing the course name (Testing), but in the server access log, it is missing the "html".

I have tried a bunch of other permutations of these changes, and nothing is getting me anything that makes any sense to me.

Thanks for any help or suggestions that can be offered. Blake

<| Post or View Comments |>

userMichael Gage - Re: AliasMatch  blueArrow
8/20/2004; 7:53:38 PM (reads: 1130, responses: 0)
Do you have the latest copy of webwork.apache-config?


You can download it from the CVS at

That's all that's coming to mind at the moment. Your analysis of where the problem lies (in grabbing the course name) seems right to me. I don't think that $webwork_courses_dir is being defined properly.

That is originally defined in global.conf, so check there as well.

-- Mike

<| Post or View Comments |>

userSteven Xiao - Re: AliasMatch  blueArrow
8/23/2004; 3:13:13 PM (reads: 1139, responses: 0)
Hi, Mike,

I just downloaded the cvs version this morning and still got the same error messages there.

Our server is

<| Post or View Comments |>