Forum archive 2000-2006

Eugene (Bud) Boman - First attempt at installing and configuring WW 2.1

Eugene (Bud) Boman - First attempt at installing and configuring WW 2.1

by Arnold Pizer -
Number of replies: 0
inactiveTopicFirst attempt at installing and configuring WW 2.1 topic started 7/11/2005; 2:51:28 PM
last post 7/13/2005; 3:53:24 PM
userEugene (Bud) Boman - First attempt at installing and configuring WW 2.1  blueArrow
7/11/2005; 2:51:28 PM (reads: 905, responses: 4)

I'm trying to upgrade from WW 1.9 to WW 2.1. I have previously install WW 1.8 and 1.9 but this is my first attempt at any version of webwork2. Just to make sure there was nothing old lying around to get in the way I repartitioned and reformatted the disks and rebuilt the OS (Debian Linux 3.1, 'sarge' distribution) from the ground up.

I then started following the directions at

I downloaded the tarballs as directed (webwork-2.1.3.tar.gz and pg-3.1.3.tar.gz) and opened them up in /opt/webwork2 and /opt/pg. Since most of the supporting software is available as a Debian package I used

# apt-get install <package-name>

to install the Debian packages and

# perl -MCPAN -e "install Module"

to install the perl modules that don't exist as Debian packages. All seemed to go well until I checked the installation using ''. It complained that the module SOAP::Lite was missing so I installed it like the other perl modules. I didn't see anything in the prior documentation about SOAP::Lite but perhaps I just missed it. If it isn't there I suggest that the installation page be modified to include it. (Not a big deal. Anyone with a clue can see what to do here, but I like Webwork a lot and I'd like to see it spread far and wide. Unfortunately, that means including the clueless (:-)

After that again all seemed to go well until I started reconfiguring Apache. I modified the /server-info stanza as follows:

<Location /server-info>
SetHandler server-info
Order deny,allow
Deny from all
Allow from

but when I tried to point my browser at

I got this error:

The requested URL /server-info was not found on this server.

Apache/1.3.33 Server at Port 80

After reading the discussion at$2545#2558

I decided that this probably wasn't much of concern so I moved on. (Should I be concerned?)

Again all seemed to go well. I now seem to have the initial page up and going at

and it is time to begin building the admin course but the instructions have stopped making sense to me. Undoubtedly this is because with regard to mysql I have to count myself among the clueless.

The installation manual says that I should

"Please read the CourseAdministrationManual for information about creating courses.

This command creates a course named admin, storing course data in in sql database named webwork_admin. --sql-user and --sql-pass specify the username and password of a user of the SQL database server that has permission to create databases.

Users are imported from the file courses/adminClasslist.lst, and the user admin (the only user listed in adminClasslist.lst) is given professor privileges."

Presumably the command referred to is the 'addcourse' coummand mentioned in the CourseAdministrationManual and apparently I'm to execute it on the command line as

addcourse --sql-user <username> --sql-pass <password>

Is that correct?

If so what user and password should I use? Were these setup for me when I installed mysql using apt-get? If not, what do I have to do to create them?

As I said I'm sure the problem is my complete ignorance of mysql. If anyone can help me out I would be most grateful. If it would be easier I'll even let you log on and do it for me provided you'll save a transcript of the session and send it to me so I can learn. Whatever is easiest.

Thanks in advance,

-- Bud Boman

<| Post or View Comments |>

userSam Hathaway - Re: First attempt at installing and configuring WW 2.1  blueArrow
7/12/2005; 3:04:54 PM (reads: 1111, responses: 0)
Since you're using WeBWorK 2.1, you'll want to use the sql_single database layout for your course data. You must first create the webwork database in MySQL, as described in the Configration for the 'sql_single' database layout section of the installation manual. Make sure the passwords you give for the webworkRead and webworkWrite accounts match those that you set in the database.conf file.

Then, follow the instructions under The 'admin' course in the course administration manual for how to create the admin course.

<| Post or View Comments |>

userEugene (Bud) Boman - Re: First attempt at installing and configuring WW 2.1  blueArrow
7/12/2005; 10:54:37 PM (reads: 1106, responses: 0)
Thanks Sam.

I reset the database layout back to sql_single in global.conf. Then I followed the directions in "Configration for the 'sql_single' database layout" -- except that I haven't yet set a password for the root account. I'll do that later. All seemed to go well.

Next I looked at the course admin manual like you suggested and ran the commands

cd /opt/webwork2/courses


addcourse admin --db-layout=sql_single --users=adminClasslist.lst --professors=admin

as root. The course seems to have been created but when I point my browser at it I see the following error message (I think I got the same error at the command line but unfortunately I let it scroll out of memory before I thought to grab it. In any case the command line error was very similar.):

error instantiating DB driver WeBWorK::DB::Driver::SQL for table problem_user: DBI connect('webwork','webworkRead',...) failed: Access denied for user: 'webworkRead@localhost' to database 'webwork' at /opt/webwork2/lib/WeBWorK/DB/Driver/ line 62 at /opt/webwork2/lib/ line 211

Now that I've read some of the mysql documentation I can almost understand this but I don't see how to fix it. It looks like the webworkRead account is being denied access to the database but I'm not sure why.

Did I overlook something?

All suggestions welcome,

-- Bud

<| Post or View Comments |>

userSam Hathaway - Re: First attempt at installing and configuring WW 2.1  blueArrow
7/13/2005; 1:09:59 PM (reads: 1112, responses: 0)
When you created the webwork database in MySQL, you should have GRNATed certain permissions on it to the webworkRead and webworkWrite users. When you did this, you should have supplied passwords for these users as part of the GRANT statements. You need to set the same passwords in the %sqlParams hash in the database.conf file, so that WW will be able to connect to the database.

<| Post or View Comments |>

userEugene (Bud) Boman - Re: First attempt at installing and configuring WW 2.1  blueArrow
7/13/2005; 3:53:24 PM (reads: 1071, responses: 0)
I'd have sworn I did that, but apparently not.

That did the trick. The admin course is now active and I've changed the password.

Looking back over this exchange it appears that I just lost confidence at the end and needed a little hand-holding for the last few steps. Thank you for providing it.

For the benefit of anyone who might find this exchange in the future I'll just mention that 'addcourse' would not overwrite the existing course. It was necessary to remove it completely with 'delcourse' and then re-create it with 'addcourse'.

Thanks again,

-- Bud

<| Post or View Comments |>