Forum archive 2000-2006

Robin Cruz - Apache::Request Installation problem

Robin Cruz - Apache::Request Installation problem

by Arnold Pizer -
Number of replies: 0
inactiveTopicApache::Request Installation problem topic started 8/20/2005; 5:19:32 PM
last post 8/30/2005; 5:20:20 PM
userRobin Cruz - Apache::Request Installation problem  blueArrow
8/20/2005; 5:19:32 PM (reads: 922, responses: 2)
When I run the script, everything reports that it is installed properly except ** Can't find Apache::Cookie ** Can't find Apache::Request I am using Mandrake 10.2. So far I have tried to install Apache:Request in a number of ways: CPAN: using perl -MCPAN -e "install Apache::Request" I get an error In file included from apache_cookie.h:20, from apache_cookie.c:16: apache_request.h:20:19: httpd.h: No such file or directory After which there are TONS of errors and nothing works CPAN: I also tried to install with Apache2 because that is what I have installed. using perl -MCPAN -e "install Apache2::Request" This actually compiles the module, but can't install because of the following errors: --

checking whether to enable maintainer-specific portions of Makefiles... no ./configure: line 19356: apxs: command not found ./configure: line 19370: apxs: command not found ./configure: line 19374: apxs: command not found ./configure: line 19378: apxs: command not found ./configure: line 19378: apxs: command not found build/ failed: no version_string found in '' for 'apache2'. configure: error: Bad apache2 binary (/) Running make test Make had some problems, maybe interrupted? Won't test Running make install Make had some problems, maybe interrupted? Won't install --

I tried downloading the source libapreq2-2.06-dev.tar.gz, and installed it, but without any change in

I have also tried installing the Mandrake RPM This installs fine, but the still reports no Request or Cookies.

Has anyone else run into this problem previously? Is there a solution? Or suggestions for other approaches?


Robin Cruz

<| Post or View Comments |>

userBob Byerly - Re: Apache::Request Installation problem  blueArrow
8/21/2005; 8:48:40 AM (reads: 1020, responses: 0)


If it helps, the "httpd.h" file your error message referred to should be in the rpm "mod_perl-devel".


I can tell you it's possible to get WeBWorK running on Mandriva 10.2, but it's a bit of a pain. Wish we'd taken better notes when we did it.


Notice that although WeBWorK doesn't work with Apache 2, it is necessary to install it and temporarily run it while compiling libapreq. We also compiled apache 1.3 from source. This may be partly paranoia; the distributed version didn't work in a previous version of Mandrake, and it's not hard.


To save time, you're better off going ahead and installing up front all the rpms that look like they may have anything to do with perl modules or apache. And if you have the room I would go ahead and install all the development libraries as well, since some will be needed to compile the perl modules you need.


Unless you're using the freeware limited version (as we are) most of these rpms should be there, even if not presented by default in the initial install. Otherwise you have to search for the ones you want on the internet. (They're readily available.) Chasing down dependencies may be a pain though. We figured out which ones we needed to download by comparing the rpms installed in 10.2 with the rpms installed on a WeBWorK development server running 10.1 (thank heavens we didn't try to upgrade them both at once!)


If you like I can send you a listing of the rpms installed on our working installation.


I'm curious about how pleasant an experience the people running Suse, Red Hat, Debian, et. al. find WeBWorK installs. I like Mandrake, but if an install on some other distro is easier, I would consider moving.


Bob Byerly

<| Post or View Comments |>

userRobin Cruz - Re: Apache::Request Installation problem  blueArrow
8/30/2005; 5:20:20 PM (reads: 880, responses: 0)
Thanks for your help, Bob. I now have it working (more or less).

<| Post or View Comments |>