WeBWorK Problems

bug(s) and Bugzilla

bug(s) and Bugzilla

by Dick Lane -
Number of replies: 2
I apologize for posting this here, but I've already spent an hour searching this website for the correct URL to Webwork's Bugzilla (? http://wwrk.maa.org/bugzilla3/ suggested by an external search), registering (with a tertiary email-address, re:warning to minimize effect of subsequent spam), confirming, and then have my login rejected.

Several problems in the LoyolaChicago/Precalculus collection do not load (since they do not load, I can not invoke the bug report button on their displayed pink pages).

Each has initial computations using
  Context("Fractions-NoDecimals") ;
before switching to
  Context("Numeric") ;

Some minor revisions [e.g., inserting a Compute()] were not a quick-fix for the first offender; I did not bother to experiment with the other two.  (My system is WW2.4 from the Ubuntu 9.04 liveDVD with only a few minor revisions from HEAD.)


For what it is worth, I append some comments about how I identified those suspects.

I was creating a collection of assignments for my colleagues to preview problems we might use this fall or spring.  To aid their quick perusal, I created a PDF file for each chapter of the text we will use (Functions Modeling Change).  Upon discovering that Webwork would not create a PDF for chapter 6, I went to a subdirectory of course/html and did a "tail -100 hardcopy.tex | less" (after a necessary su) to get an idea about what succeeded just before failure --- this gave me a clue about where to start a probe of individual problems.  [I suspect there is a WW logfile with relevant information, but this procedure used tools familiar to me.]
In reply to Dick Lane

Re: bug(s) and Bugzilla

by Jason Aubrey -
Hi Dick,

Sorry about difficulty finding the new Bugzilla. We're moving everything to MAA, and bugzilla is now there at wwrk.maa.org/bugzilla3/. We have put in redirects from the old bugzilla, but other than that we haven't replaced all references to the old site because the url will change eventually to webwork.maa.org/bugzilla3/ or possibly bugzilla.webwork.maa.org. We'll probably have that all figured out next week.

At any rate, did you get any error messages when you tried to login to Bugzilla, or just that your login was rejected? I'll check this out.

In reply to Jason Aubrey

Re: bug(s) and Bugzilla

by Dick Lane -
Hi Jason,
    The reply to my registration began
++++++++++ begin quote ++++++++++
bugzilla-daemon@webwork.maa.org to me show details 3:47 PM (5 hours ago)
Bugzilla has received a request to create a user account
using your email address ([gmail account for use with course]).

To continue creating an account using this email address,
visit the following link by June 17th, 2010 at 17:47 EDT:

++++++++++ end quote ++++++++++

    My initial attempts to login at http://wwrk.maa.org/bugzilla3/ elicited response "The username or password you entered is not valid."  [note the difference between webwork.maa.org and wwrk.maa.org, neither of which was included in "the following link"].    On the other hand, I just tried again (wwrk.maa.org) and got in.

    On the third hand, once in, none of the Component choices match the LoyolaChicago library and Version:unspecified is fixed.  It is not clear which Severity keyword is appropriate --- the individual problems stall Webwork, but a Stop command in the web-browser takes effect and none of the 3 problems seems to compromise system integrity (but one browser session crashed after a 7 minute stall).  Platform is probably WW system rather than the Ubuntu OS of server or the OS of my client.  I suspect the Priority coding goes from Low (P1) to High (P5), but no adjacent help provides a clue.
    In any event, I just copy+pasted the Webwork-specific part of my report into Bugzilla.