Problems not showing up after upgrade

Problems not showing up after upgrade

by Robin Cruz -
Number of replies: 7
Hi, All,
I am trying to get an installation from the Vanilla LiveDVD (WW 2.4 on Ubuntu 10.04) working on a virtual machine. I believe it was working until I upgraded Ubuntu last week--which broke it big time. I've gone through the Installation manual for 2.4, the Upgrading WeBWorK manual and the Release Notes for 2.4 and have if running again, but there are a few problems I cannot figure out. I backed the webwork2 and pg folders back to the trunk version with SVN.

1) The problems will not display and the "map" at the top of the problem page is "odd". It is not displaying the text correctly. It looks like this when I select a problem to work:

webwork > test1 > algebra_01_01_algebraicexpressions > 1 Logged in as rcruz.
Log Out
Algebra 01 01 AlgebraicExpressions: Problem 1
This set is visible to students.
This set is visible to students.

I think first line of text shown above used to have upper case letters???

2) It will generate a hardcopy of a set, but I get a message box with:
/tmp/70YC2nSR.pdf.part could not be saved, because the source file could not be read.
However, it generates the hardcopy. I can open it from the Hardcopy folder and the problems show up just fine in the PDF.

3) I tried to see if the problems would show up in the LibraryBrowser and they show up fine if you use the "From This Course" button. But, if I click the "Try it" option, the same thing happens as in 1) . If I try to see the problems from the "Set Definition Files" button I get the following error:

WeBWorK error

An error occured while processing your request. For help, please send mail to this site's webmaster (webmaster@localhost), including all of the following information as well as what what you were doing when the error occured.

Mon Aug 29 00:17:17 2011

Warning messages

Error messages

/opt/webwork/Problems/MAT105_Templates//MAT105_Templates is a recursive symbolic link at /usr/share/perl/5.10/File/ line 557.

Call stack

The information below can help locate the source of the problem.

  • in File::Find::Follow_SymLink called at line 1179 of /usr/share/perl/5.10/File/
  • in File::Find::_find_dir_symlnk called at line 710 of /usr/share/perl/5.10/File/
  • in File::Find::_find_opt called at line 1297 of /usr/share/perl/5.10/File/
  • in File::Find::find called at line 170 of /opt/webwork/webwork2/lib/WeBWorK/ContentGenerator/Instructor/
  • in WeBWorK::ContentGenerator::Instructor::SetMaker::get_set_defs called at line 704 of /opt/webwork/webwork2/lib/WeBWorK/ContentGenerator/Instructor/
  • in WeBWorK::ContentGenerator::Instructor::SetMaker::browse_setdef_panel called at line 799 of /opt/webwork/webwork2/lib/WeBWorK/ContentGenerator/Instructor/
  • in WeBWorK::ContentGenerator::Instructor::SetMaker::make_top_row called at line 1374 of /opt/webwork/webwork2/lib/WeBWorK/ContentGenerator/Instructor/
  • in WeBWorK::ContentGenerator::Instructor::SetMaker::body called at line 152 of /opt/webwork/webwork2/lib/WeBWorK/
  • in WeBWorK::Template::template called at line 494 of /opt/webwork/webwork2/lib/WeBWorK/
  • in WeBWorK::ContentGenerator::content called at line 198 of /opt/webwork/webwork2/lib/WeBWorK/
  • in WeBWorK::ContentGenerator::go called at line 370 of /opt/webwork/webwork2/lib/

Request information

Add problems to Target Set: Select a Set from this Course Algebra_01_01_AlgebraicExpressions Algebra_01_02_OperationsWithRealNumbers Algebra_01_03_GraphingFunctions Algebra_01_04_SolveLinearEq Algebra_01_05_ProblemSolvingAndFormulas Algebra_01_06_Exponents Algebra_01_07_ScientificNotation Algebra_02_01_IntroFunctions Algebra_02_02_GraphsOfFunctions Algebra_02_03_AlgebraOfFunctions Algebra_02_04_LinearFunctionsAndSlope Algebra_02_05_PointSlopeFormofLine Algebra_03_01_SystemOfLinearEq Algebra_03_02_ProblemSolvingBusinessApp Algebra_04_01_LinearInequalities Algebra_04_02_CompoundInequ Algebra_04_03_AbsoluteValue Algebra_05_01_IntroPolynomials Algebra_05_02_MultiplyPolynomials Algebra_05_03_FactoringByGrouping Algebra_05_04_FactoringTrinomials Algebra_05_05_FactoringSpecialForms Algebra_05_06_Factoring Algebra_05_07_PolyEqAndApplications Algebra_06_01_MultDivRationalExpressions Algebra_06_02_AddSubRationalExpressions Algebra_06_06_RationalEquations TEST_PROBLEMS

or Problems from
Method POST
URI /webwork2/test1/instructor/setmaker/
HTTP Headers
Keep-Alive 115
Accept-Charset ISO-8859-1,utf-8;q=0.7,*;q=0.7
User-Agent Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20110628 Ubuntu/10.04 (lucid) Firefox/3.6.18
Accept text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Connection keep-alive
Content-Length 20762
Accept-Encoding gzip,deflate
Content-Type multipart/form-data; boundary=---------------------------180332438216272680691322632690
Cookie __utma=33027372.845525900.1247692761.1314560451.1314596257.385; __utmz=33027372.1311555009.343.1.utmccn=(direct)|utmcsr=(direct)|utmcmd=(none); __utmc=33027372; jsMath=font%3Asymbol%2Cwarn%3A0
Accept-Language en-us,en;q=0.5

Here is some more info: I currently have
Ubuntu 10.04.3 LTS
Perl v5.10.1
Apache2 2.2.14 (Ubuntu)
Mysql 5.1.41-3unbuntu12,10
Note, that I set this up with Option A and C.

Help! Classes start this Friday -- rac

ps I'm attaching a copy of that I have in the global.conf file
In reply to Robin Cruz

Re: Problems not showing up after upgrade

by Michael Gage -

Hi Robin,

The error message displayed indicates that you have a symlink in the Problems directory MAT105_Templates/MAT105_Templates which is linking back to itself. That may not be the cause of the other problems however.You should just delete the symlink inside the directory.

I'm a little unsure of which version of webwork you are looking at (current trunk? or the tagged 2.5.0 version) -- there was a lot of updating of .css files this summer aimed at improving accessibility.


To make sure you are actually using the current .css files do the following

mv math2.css
ln -s ../../conf/templates/math2/math2.css math2.css

and do the same thing for math3.css

this will make sure that you are using the current .css files.
(You could also copy the files from the conf/templates/math* directories into the webwork2/htdocs/css directories, but the method above means that you won't have to redo the copy everytime you get an updated .css file in templates.)

I think this will fix the the "look" you are noticing on the bread crumb line. We've moved away from using images and toward using CSS/JavaScript (aka AJAX) methods for display. This a helps accessibility and also allows us to use different languages (localization).

Not sure about the hard copy problem -- that could be some kind of permissions problem -- why is it trying to write into the /tmp directory directly?? -- but fix the other problems first and see what happens.
In reply to Michael Gage

Re: Problems not showing up after upgrade

by Robin Cruz -
Thanks, Mike for the quick response.

I removed the (don't know how it got there) symlink and now both the hardcopy function, problems showing up and "bread crumb" list are working again. I'll have to do more testing to make sure the problem templates are working, but as of now, they seem to be fine.

I did the other changes you suggested for the .css files. When I was reading through the forums for help on this, I redid the webwork2 and pg folders to the current trunk version as of last Sunday. Please remind me how to find out what a WeBWorK folder's version number?? We have been using a slightly modified version of union.css (the colors were changed to our school colors and the webwork icon was modified). The /webwork2/conf/templates/union folder did not have a file in it called union.css. I put a copy of the union.css from the /webwork2/htdocs/css folder and added a link like the one for the math2.css link. It changes the layout to our "C of Idaho'ed union" layout, but now problem #1 returns--the problems don't show up and the bread crumb list is broken. If I use the math2 layout, everything seems to work. I'd like to use our "union" layout. Is there union.css file that works with all of this?

Thanks so much. - rac
In reply to Robin Cruz

Re: Problems not showing up after upgrade

by Robin Cruz -

I've been testing the installation using the math2 theme and the important stuff, like the problems showing up and functioning, seems to be working, more or less. One issue is that the "Set Info" box which doesn't seem to be fixed down. I'm sending two screen shots so you can see what I'm talking about--I am using a larger text size in my browser, by the way. Also the "bread crumb" list is still not displaying the text as I think it should.


Attachment Set_Info_Examples.png
In reply to Robin Cruz

Re: Problems not showing up after upgrade

by Michael Gage -
I've noticed this bug too, with varying results in varying browsers.  CSS is good in that it allows a lot more flexibility for presentation in different formats (including mobile devices) but it can be pretty tricky.

I'll put Grant He to work on this as well -- I expect we'll have a fix soon but since but it still might take until next weekend since everything is starting up.

-- Mike

In reply to Robin Cruz

Re: Problems not showing up after upgrade

by Michael Gage -
there isn't a version for the union.css yet -- the student who has been redoing the .css files will probably be working for us this fall semester and I'll make this one of his projects.  It might be a few weeks before it's done however.
In reply to Michael Gage

Re: Problems not showing up after upgrade

by Robin Cruz -

OK. I'll go ahead and "turn my people loose" on what I have now. Hopefully, Grant can make it prettier soon.

Thanks for your quick response, I might even be able to get ready for my classes this Friday, now!!


In reply to Robin Cruz

Re: Problems not showing up after upgrade

by Michael Gage -
If you upgrade the contents of 
conf/templates/math2   and use the math2 theme choice then
the info box should be over to the right now and not sprawled across the screen. 

The bread crumbs seem about right to me -- you should see little arrows
between nodes and that is what you seem to have in the screen shots above.  We're moving away from images so the arrows may look a little different now.