WeBWorK Problems

Issues with proctoring info required

Issues with proctoring info required

by Alasdair McAndrew -
Number of replies: 2
I have made my homework sets available as Gateway quizzes, but suddenly students were being asked for Proctor information - even though I'd never set any proctoring information anywhere.

As an experiment I set a proctor password "test", but students still couldn't log on. Nor could I access the tests as a student, as I've no idea what the proctor login was supposed to be. I tried "admin" but that didn't work.

I tried setting the tests back to (unproctored) gateway, and rebooting apache, and now students are getting the famous error messages:

Undefined subroutine &WeBWorK::PG::Translator::fileFromPath called at /opt/webwork/pg/lib/WeBWorK/PG/Translator.pm line 543.

I've had this before, and an apache reboot fixed it.

I'm in a bit of a bind here, and don't know what to do. How do I set a proctor username and password for the students, even though my homework set is set up as a plain gateway quiz? Even better, how do I get WW to stop insisting that students enter proctor information, when my tests are set up not to require it?

Note that this has only been happening recently. A previous problem (not being able to save test configuration due to errors relating to reduced scoring dates) I got round by entering reduced scoring dates, even though I don't want them. My WW simply refused to work otherwise. I'd like to be able to work without proctoring or reduced scoring, neither of which I want nor need.


WeBWorK © 1996-2014 | theme: math4 | ww_version: develop | pg_version: 2.9| The WeBWorK Project
In reply to Alasdair McAndrew

Re: Issues with proctoring info required

by Michael Gage -
This error shows up, but not consistently if the operating system is upgraded to use perl 5.16 or higher.  (The new operating system has an asynchronous loading pattern which is not allowed for in the original code.)  The pull requests
webwork2: #465 and pg #148 address this issue.  Both pull requests need to be applied at once to the develop branch  since files are changed in both the webwork2 and pg directories.

After further testing these pull requests will become part of the develop release.

See thread http://webwork.maa.org/moodle/mod/forum/discuss.php?d=3347#p8696  for a discussion of this error message as we tried to figure out what was going on.
In reply to Michael Gage

Re: Issues with proctoring info required

by Alasdair McAndrew -
Many thanks for that reply! As soon as I learn how to make a git pull request I'll apply those changes and see what happens. I'm using Perl 5.18.2 in Ubuntu 14.04 64bit.

When I enter the /opt/webwork/webwork2 directory, "git branch" returns

* ww3

I'm not quite sure what's going on here: I downloaded and installed WW using Jason Aubrey's "ww_install.pl" script. And I'm not sure now how to use git to make incremental changes to my installation.

Any pointers to how to manage single requests with git will be gratefully received!

Thanks again,