OPL-update problem

OPL-update problem

by Douglas Brown -
Number of replies: 2

Similar to an issue detailed in another thread below , when I run OPL-update I get the error:

Cannot open /opt/webwork/webwork2/htdocs/DATA/tagging-taxonomy.json at /opt/webwork/webwork2/bin/OPL-update line 516.

I am running Ubuntu 14.04 with Apache 2.4 and WeBWorK 2.11.

If I try any of the suggested options (sudo OPL-update, sudo -E OPL-update, OPL-update as root) I get replies that the file or command does not exist. When I list the files in htdocs/DATA, all that appears is a README file. Should this be the case and, if not, what do I need to do? I have tried starting from scratch with the install with the same result.

In reply to Douglas Brown

Re: OPL-update problem

by Michael Gage -
The error means that you don't (normally) have permission to write in the directory


sudo -E ./OPL-update

Depending on your settings sudo may not look for files in the current directory unless you add the ./

The other possibility is that the command at the top of OPL-update used to run the script is not finding perl. (#!/usr/bin/env perl)

You could try sudo -e /usr/bin/perl OPL-update
(to see where your perl application is installed type
which perl

In desperation you can change permissions on DATA to 777 and run the command as
yourself. That should also work.
Hope this helps.

In reply to Michael Gage

Re: OPL-update problem

by Douglas Brown -
Thanks, Mike. I did have to go in a change the permissions to allow the group to write to DATA (I'm not sure why the process in the installation manual did not work the first time through). Then running sudo -E ./OPL-update did the trick.

Thanks again,