WeBWorK Problems

Cannot unpack problem archive

Cannot unpack problem archive

by Homer White -
Number of replies: 2
Working on a Mac, I created an archive from a directory of problems

tar -zcvf CalculusET3EWebWork2016.tgz CalculusET3EWebWork2016

and tried to upload using the file manager but the following error message:

Can't unpack 'CalculusET3EWebWork2016.tgz': command returned signal 18446744073709551487

The funny thing is that I have archived this directory before and uploaded it by the same method, and it has worked in the past.

What does the message mean?

Note: I should point out that I can unpack the archive by logging in to the server and running

sudo tar -xzvf CalculusET3EWebWork2016.tgz

and then all is well.
In reply to Homer White

Re: Cannot unpack problem archive

by Danny Glin -
Some thoughts:
  • There may be more information in the apache error log, possibly including a more meaningful error message.
  • It could be a permissions issue. ┬áMake sure that the course templates directory is writeable by the web server.
  • Are there any file names with special characters? ┬áThis sometimes causes problems.
In reply to Danny Glin

Re: Cannot unpack problem archive

by Homer White -
I'll check the apache error log. No problems in the other areas.

IT is a bit stretched at my little College, so our Department is on its own, with WeBWorK hosted on Digital Ocean. We are still learning.

Thanks!

Homer