WeBWorK Problems

submitting to OPL/Contrib

submitting to OPL/Contrib

by Joel Trussell -
Number of replies: 2
I'm having difficulty getting started submitting. I have read the usual OPL and Submitting to OPL document, installed github. I have a local repository. I've added lots of problems, commited them on and tried to push After what I thought was a successful push I went online and made a pull request - I never saw anything that indicated that it had been acted on. Now I'm getting errorson the push after adding and commiting a new bunch of problems. The error is

$ git push https://github.com/hjtrussell/webwork-open-problem-library
To https://github.com/hjtrussell/webwork-open-problem-library
! [rejected] master -> master (non-fast-forward)
error: failed to push some refs to 'https://github.com/hjtrussell/webwork-open-problem-library'
hint: Updates were rejected because the tip of your current branch is behind
hint: its remote counterpart. Integrate the remote changes (e.g.
hint: 'git pull ...') before pushing again.
hint: See the 'Note about fast-forwards' in 'git push --help' for details.

my github screen looks like

any help is appreciated
In reply to Joel Trussell

Re: submitting to OPL/Contrib

by Danny Glin -
I am by no means a git expert, but since no one else has responded yet, I'll tell you what I can.

I don't see your pull request to the main openwebwork repository.  My guess would be that it never got sent, possibly because of some missing step in the process.  Did you get a pull request number when you submitted the pull request?

Regarding the error, I took a look at your repository, and your last commit appears to have deleted all of the OPL problems except for the ones that you have added to Contrib.  It looks like now the repository on your computer and the one in your github account are out of sync, which is why it is rejecting your push, since it can't reconcile the changes on both ends.

Unfortunately fixing the latter problem is beyond my github skills, so hopefully someone better at git can chime in with some suggestions.
In reply to Danny Glin

Re: submitting to OPL/Contrib

by Joel Trussell -
Thanks - I've tried another pull request and gave a comment about the out of synch problem. My last couple of commits didn't seem to regisiter. My github page shows  my list from my local repository (above) and the commits that seem to be recognized (below)