WeBWorK Main Forum

Upgraded, now PGstandard error

Upgraded, now PGstandard error

by Wesley Burr -
Number of replies: 3
Hi, folks,

Recently upgraded my 2.12-r installation to the rel-ww2.14. I followed the instructions on the
wiki, and pointed the branches to the latest and then pulled. It seems to have worked, all
modules present, everything functional, until I login and try to make a test homework set.

Any problem, even a blank one, comes up with the following error:

 Problem1 1. ERROR caught by Translator while processing problem file: 
TrentProblems/blankProblem.pg **************** 
ERRORS from evaluating PG file: Error detected while loading [PG]/macros/PGstandard.pl: 
PG_macro_file_eval detected 
error at line 123 of file [PG]/lib/PGloadfiles.pm Can't 
use string ("") as a subroutine ref while "strict refs" in use at [PG]/lib/PGcore.pm 
line 730, chunk 1. The calling package is PGloadfiles Died within 
PGloadfiles::compile_file called at line 171 of [PG]/lib/PGloadfiles.pm from within 
 PGloadfiles::loadMacros called at line 517 of [PG]/macros/PG.pl from within 
main::loadMacros called at line 23 of (eval 2504) 
So, I'm assuming something went wrong, or there was a mismatch between the upgrade to
the rel-ww2.14 for /webwork2 and rel-PG-2.14 for /pg, since this is happening on a
blankProblem (default).

Has anyone seen a similar error before, and might be able to point me to where to start for/
trying to troubleshoot? Absolute worst case, I can wipe the current installation and just
install 2.14 from scratch, but that's obviously not preferred.

- Wesley
In reply to Wesley Burr

Re: Upgraded, now PGstandard error

by Danny Glin -
I can give some general suggestions which may or may not help with your issue.
  • It looks like you upgraded both webwork and pg. That's the first thing to check. If they're both the same version then I would expect them to work together.
  • Have you restarted apache? I've been caught by that before.
It looks like an issue with loadMacros. Have you checked the permissions on your pg directory? Can WeBWorK read the macro files?

In reply to Danny Glin

Re: Upgraded, now PGstandard error

by Michael Gage -
Are you missing CPAN modules? Is there an error message in the apache log to that effect?

I think the relevant error message is at line 730 of PGcore.pm (+- a few lines).

If so that means something about maketext didn't get set up properly.

(The function maketext is used in PG code to translate into other languages
maketext("you're answer is wrong") get's replaced with the appropriate message in what ever language is being used. )

maketext() has been around for a while but there have been some recent updates to it which might make something go wrong in 2.14 that worked on 2.12 but I haven't experienced it personally or heard previous reports about it.

If you are working on a new machine it's possible that you didn't get all of the cpan modules installed for Localization.

-- Let us know what comes of this when you figure out the problem.

In reply to Michael Gage

Re: Upgraded, now PGstandard error

by Wesley Burr -
I'm almost certain that in the upgrade process I borked some directory permissions. In the end, I couldn't figure out anything useful, and it wasn't that hard to just wipe the installation and setup from scratch with 2.13. Which is what I ended up doing, and it's been working almost perfectly since. Posting a new thread to ask about a new problem I'm running into with Rserve, which was working, and is now not.

Thanks for the responses, and apologies for the late ping-back - the semester has gotten away from me!