WeBWorK Main Forum

Hardcopy generator problem

Hardcopy generator problem

by Ted Cox -
Number of replies: 2
All of a sudden the hardcopy feature for my course has stopped working -- it had worked fine before. Neither pdf and tex files work properly. I am including the error messages below. Any help would be apprecitated. Thanks,

Hardcopy Generator

4 errors occured while generating hardcopy:

* Failed to convert TeX to PDF with command 'cd /usr/local/webwork2/courses/MAT521_F07/html/tmp/hardcopy/work.cMBFIWrS && /usr/bin/pdflatex --shell-escape >pdflatex.stdout 2>pdflatex.stderr hardcopy'.
* No TeX log was found.
* Failed to rename 'hardcopy.pdf' to 'MAT521_F07.jtcox.Week-2.pdf' in directory '/usr/local/webwork2/courses/MAT521_F07/html/tmp/hardcopy/work.cMBFIWrS':

* Final hardcopy file '/usr/local/webwork2/courses/MAT521_F07/html/tmp/hardcopy/work.cMBFIWrS/hardcopy.pdf' not found after calling 'generate_hardcopy_pdf': No such file or directory

You can also examine the following temporary files: hardcopy.log, hardcopy.aux, pdflatex.stderr, hardcopy.tex, pdflatex.stdout

Hardcopy Generator

2 errors occured while generating hardcopy:

* Failed to rename 'hardcopy.tex' to 'MAT521_F07.jtcox.Week-2.tex' in directory '/usr/local/webwork2/courses/MAT521_F07/html/tmp/hardcopy/work.mFmESHEE':

* Failed to move hardcopy file 'hardcopy.tex' from '/usr/local/webwork2/courses/MAT521_F07/html/tmp/hardcopy/work.mFmESHEE' to '/usr/local/webwork2/courses/MAT521_F07/html/tmp/hardcopy':

A hardcopy file was generated, but it may not be complete or correct: Download Hardcopy
In reply to Ted Cox

Re: Hardcopy generator problem

by Davide Cervone -
Looks to me like a permissions issue. Check that


has write access for the web server process, and at least read permission on the directories above it. (Actually, the html/tmp directory will need write access as well.)

In reply to Davide Cervone

Re: Hardcopy generator problem

by Ted Cox -
Arghh! Now somehow things are even worse. I get the following when I try to get a hardcopy:

Not Found

The requested URL /webwork2_course_files/MAT521_F07/tmp/hardcopy/MAT521_F07.jtcox.Week-2.pdf was not found on this server.

Apache/1.3.36 Server at webwork.syr.edu Port 81

In the apache error_log I see:

[Tue Sep 11 14:30:07 2007] [warn] [client] [/webwork2/MAT521_F07/hardcopy/] Preserved temporary files in directory '/usr/local/webwork2/courses/MAT521_F07/html/tmp/hardcopy/work.wpDkpesX'.
[Tue Sep 11 14:30:07 2007] [error] [client] File does not exist: /usr/local/webwork2/courses//html/

Notice // above and the missing course name.

Last year using webwork 2.2.1 I had a problem like this which was apparently due to aliasmatch in webwork.apache-config and solved it as suggested by putting in aliases for each course. Now with webwork 2.3.2 this workaround doesn't work, meaning that apache displays the contents of a directory instead of the login page.

I am totally confused now.