WeBWorK Main Forum

WebWork2, Radware WAF - giving 502 Bad Gateway (always looping)

WebWork2, Radware WAF - giving 502 Bad Gateway (always looping)

by L Ng -
Number of replies: 0

Hello everyone.

We are trying to implement a WAF setup using a product from a company called RADWARE. Other sites we have seem to be working fine except for WebWork.

WebWork is special I think..

For some reason, when we hit the site, it always loops trying to redirect to the site and fails with a 502 Bad Gateway error. The server logs don’t show anything. 

The site is https://testwebwork.oursite.ca and when the user hits it, it will be redirected to https://testwebwork.oursite.ca/webwork2 by doing a meta tag redirect in the index.html page under the /var/www/html directory under our RedHat O/S.  

This has always worked before we tried to use WAF…

Basically all this WAF product does is to use their dns which stores the public IP of https://testwebwork..oursite.ca) but redirects to our source server’s (the webwork server) IP which then goes to the webwork server and the webwork server’s index.html (/var/www/html/index.html) redirects it to https://testwebwork..oursite.ca/webwork2 url.  WAF set up as a security measure.

I even tried and remove the redirection and still the same looping exists and 502 Bad Gateway message.

Any ideas why the redirection does not work? Which .conf files do I need to consider changing or any other configuration… thoughts?

I am not a network expert so any help is appreciated.

Thank you.