mathquill on 2.18

mathquill on 2.18

by Omar Hijab -
Number of replies: 3


I upgraded from 2.16 to 2.18 and everything worked, including LTI, except the mathjax/mathquill rendering in answer entry boxes. I have JS console errors of the form

GET net::ERR_ABORTED 404 (Not Found)

I then installed 2.18 from scratch with same result.

I am using option 2 (proxy via apache2). When in terminal, the command 

wget -m http://localhost:8080/webwork2

results in two folders 

but the command
wget -m http://localhost:8080/pg_files

results in not found error.

My files webwork2.apache2.4.conf and webwork2.apache2.4.dist.conf 

are identical.

My files

webwork2.mojolicious.yml and webwork2.mojolicious.dist.yml

differ only in the secret and enabling debugging.

What am I missing? 

Thank you for any help on this.


In reply to Omar Hijab

Re: mathquill on 2.18

by Danny Glin -

Did you run `npm ci` in /opt/webwork/pg/htdocs?

In reply to Danny Glin

Re: mathquill on 2.18

by Omar Hijab -
Good morning Danny,

Yes I did.

I just figured it out. I'm running Ubuntu 2204 with node 20.*, which, according to the install instructions, should be ok. Well, this morning, I downgraded to node 16.*, and the errors disappeared, everything works.

Maybe the install instructions for 2.18 should be updated.

Thank you and happy new year,
In reply to Omar Hijab

Re: mathquill on 2.18

by Glenn Rice -
Node version 20 works fine for webwork2. I have been using that with webwork2 for a while now. It is unlikely that downgrading to node 16 is what actually fixed the problem. Most likely running "npm ci" again in both the webwork2/htdocs and pg/htdocs locations and then restarting the webwork2 app would have fixed the problem without downgrading.