Forum archive 2000-2006

luoy@m... - hardcopy generating problem

luoy@m... - hardcopy generating problem

by Arnold Pizer -
Number of replies: 0
inactiveTopichardcopy generating problem topic started 7/23/2004; 11:23:02 AM
last post 7/23/2004; 7:49:54 PM
userluoy@m... - hardcopy generating problem  blueArrow
7/23/2004; 11:23:02 AM (reads: 1250, responses: 6)
When generating hardcopy, I have following at url: /webwork2/test2/hardcopy/

Hardcopy Generator Software Error WeBWorK has encountered a software error while attempting to process this problem. It is likely that there is an error in the problem itself. If you are a student, contact your professor to have the error corrected. If you are a professor, please consut the error output below for more informaiton.

Error messages Failed to generate PDF from tex

Error context Call to /usr/local/teTeX/bin/i686-pc-linux-gnu/pdflatex failed: No such file or directory

Some pdf output was produced and is available here. ...

Howerver "/usr/local/teTeX/bin/i686-pc-linux-gnu/pdflatex" does exists and is a link to pdftex, which is excutable.

Any idea?


Frank x96099

<| Post or View Comments |>

userluoy@m... - Re: hardcopy generating problem  blueArrow
7/23/2004; 11:24:39 AM (reads: 1432, responses: 0)
Also, when click on "some pdf output was produced and is available here" as above, I do see the correct pdf file!

<| Post or View Comments |>

userJohn Jones - Re: hardcopy generating problem  blueArrow
7/23/2004; 1:55:15 PM (reads: 1418, responses: 0)
It wasn't saying that pdflatex didn't exist, but that some file pdflatex tried to access did not exist. Maybe the error was innocuous in this case which is why correct looking output was produced.

I would check log files (apache error log if you haven't set a special one) for more information on what went wrong. Otherwise, have webwork retain temp files so that it leaves the .tex file behind. Then run pdflatex on it by hand to see if it generates some error messages.


<| Post or View Comments |>

userSam Hathaway - Re: hardcopy generating problem  blueArrow
7/23/2004; 3:05:43 PM (reads: 1437, responses: 0)
To retain hardcopy temp files, edit the file webwork2/lib/ContentGenerator/ Comment out line 541, which reads "rmtree($wd, 0, 0);".

<| Post or View Comments |>

userluoy@m... - Re: hardcopy generating problem  blueArrow
7/23/2004; 3:09:10 PM (reads: 1445, responses: 0)
But how can I tell wework to retain the temp file? Thanks.

<| Post or View Comments |>

userluoy@m... - Re: hardcopy generating problem  blueArrow
7/23/2004; 3:22:47 PM (reads: 1464, responses: 0)
There is nothing in apache error log for this. I have apache loglevel set to debug.

Is there a way to set webwork2 debugging level?

<| Post or View Comments |>

userMichael Gage - Re: hardcopy generating problem  blueArrow
7/23/2004; 7:49:54 PM (reads: 1455, responses: 0)

Look carefully at the pdf output. I suspect that there is in fact an error -- perhaps one of the problem template files could not be read? or perhaps there was an error in interpreting it, or finally in locating an auxiliary file required by the problem. (This last is frequently a permissions error.) If you locate the problem that has the error, then you can usually detect the same error while viewing that problem from the web instead of as hard copy.) One exception to this -- you may have set different files for the header, and the screen header file may be interpreting correctly, but the file being used for the hardcopy header is not being interpreted correctly.

By the way. There is a new Tutorial on managing a WeBWorK2 course (aka "Day in the life of WeBWorK2 professor") document rewritten by Liam Rafferty and Arnie Pizer for WeBWorK2.

<| Post or View Comments |>