WeBWorK Main Forum

Hardcopy Problem

Hardcopy Problem

by Douglas Brown -
Number of replies: 2
When trying to generate a hardcopy from the following pg file:

This set shows how to write simple WeBWorK problems and introduces you to the most common constructions.

I get the following error message:

  • Failed to convert TeX to PDF with command 'cd /opt/webwork/courses/1132-01/html/tmp/hardcopy/work.8Er08lOG && /usr/bin/pdflatex --shell-escape >pdflatex.stdout 2>pdflatex.stderr hardcopy' (exit=1 signal=0 core=0).

  • First error in TeX log is:

    ! Missing $ inserted. <inserted text> $ l.571 TEXT(EV3P(<<'END_ TEXT')); I've inserted a begin-math/end-math symbol since I think you left one out. Proceed, with fingers crossed.

I have tried various other standard header files with the same result. The hardcopy will generate when I continue, but I'd rather not have students encountering the error message. All was well last semester - any thoughts?

Thanks, Doug

In reply to Douglas Brown

Re: Hardcopy Problem

by Danny Glin -
I was able to print this without any issues on our Webwork system here. What version are you running?
I know a couple of years back I had an issue with printing questions which had no answer blanks, but I believe that it was fixed a couple of versions back.
Have you taken a look at the hardcopy.tex file that the problem generated? If you look around line 571 where it indicates the first problem is, you may be able to spot what's causing it. If not, perhaps you could post that section of the hardcopy.tex file to see if someone here has some insight.

In reply to Danny Glin

Re: Hardcopy Problem

by Douglas Brown -
Thanks, Danny. It turns out (after looking at hardcopy.tex) that this is a problem addressed earlier - the problem was not with the header file but the problem set. In particular, the presence of $CARET.

Thanks for your help.