Need Help With Moodle Integration

Need Help With Moodle Integration

by Jim Fischer -
Number of replies: 4
I am working on integrating moodle (2.X) with our WW (2.11) installation. I was able to get moodle up and running (2.6) and tried following the steps for moodle integration posted in the wiki.

Namely, I first downloaded the wwassignment5 to the ubuntu 14.04 server, then moved the wwlink, and wwassignment directories into moodle, as indicated in the first two steps.

Im stuck on the step 3 where I log into moodle as admin to set up the ww module. I can't "see" the ww module or figure out how to get moodle to recognize "it" has been placed in the moodle directories.

I have tried updating moodle, to a later stable version. A seemed to have messed something up in the git process, a skill I get better at each time I use git!

I checked out branch 2.9, did a git pull, all seemed to go fine. However, when I open moodle and check notifications, it still says Im running 26. I used the git instructions posted at Moodle: In the moodle directory

sudo git branch --track MOODLE_29_STABLE origin MOODLE_29_STABLE
sudo git checkout MOODLE_29_STABLE
sudo git pull

I guess I have two issues:

1. How to correctly upgrade Moodle using git. Not sure why the git processes looks good with no errors, but version is not updating when I open moodle in a browser and check notifications.

2. How to find and set up the wwassignment(5) module within Moodle

Any help would be greatly appreciated.

In reply to Jim Fischer

Re: Need Help With Moodle Integration

by Jim Fischer -
Its looking like there is something not quite right about my initial moodle installation. Im getting some help at the moodle forum. Also, I am aware of the missing "/" in the above commands, that was a typo. Once I sort this out, I will post what learn.

In reply to Jim Fischer

Re: Need Help With Moodle Integration

by Michael Gage -
If your code base for moodle actually changed then perhaps you aren't calling the right code with your browser? some mismatch in the url?

Also it never hurts to restart the apache server -- although I don't believe you should have to for this update. 
In reply to Michael Gage

Re: Need Help With Moodle Integration

by Jim Fischer -
Thanks Mike. When I installed Moodle (26), I followed the steps here, except I didnt install apache, mysql, since they were already installed for webwork

Are these the correct steps? Well at least they produced a "working" moodle! I have not tested the moodle thoroughly, but it is present and accessible.

My plan is to ensure I have moodle installed correctly, then I will come back to the wwassignment module installation and bridging.


In reply to Jim Fischer

Re: Need Help With Moodle Integration

by Jim Fischer -
You were correct Mike. The moodle installation instructions put moodle into two different locations: /opt/moodle and also /var/www/html/moodle

The one that apache is looking at is in the latter of the two and /opt/moodle is where I was working. Now I am able to update moodle correctly and am running version 2.7. However, I am running into an error when trying to install the wwassignment module. Hopefully the following makes sense to someone:

Here is what I did:
moved wwlink directory into /var/www/html/moodle/blocks
moved wwassignment directory into /var/www/html/moodle/mod

When I open moodle at webpage it takes me immediately to a page for plugin checks

The only option is at the bottom of the page: "update moodle database now". When I click on this another page opens up with the following error (if I remove the two directories, the error goes away):

Oregon Tech Math Development for Moodle

Plugin "mod_wwassignment" is defective or outdated, can not continue, sorry.

More information about this error

Debug info: Missing version.php
Error code: detectedbrokenplugin
Stack trace:
  • line 591 of /lib/upgradelib.php: plugin_defective_exception thrown
  • line 420 of /lib/upgradelib.php: call to upgrade_plugins_modules()
  • line 1615 of /lib/upgradelib.php: call to upgrade_plugins()
  • line 434 of /admin/index.php: call to upgrade_noncore()
clicking on More information about this error produces:


Note: You are currently viewing documentation for Moodle 2.7. Up-to-date documentation for the latest stable version of Moodle may be available here: error/moodle/detectedbrokenplugin.

A broken plugin, such as a module, has been detected. In order for the upgrade to proceed, the broken plugin should be deleted.

In the case of a Theme, then it is more than likely there is a file that has not been renamed correctly, or the theme is missing a vital component like a version.php, or that the version.php is not correct in some small detail, usually the plugin version. To correct this, you must add the theme/THEMENAME/lang/en/theme_THEMENAME.php file, where THEMENAME is the name of the theme folder. Inside that file, add the string "$string['pluginname'] = 'THEMENAME'; ". Make THEMENAME the name of your theme, however you want it displayed in the Theme selector.

Also, make sure to change your config.php file and version.php file to reflect the correct name:

In config.php: $THEME->name = 'NAME';

In version.php: $plugin->component = 'theme_NAME'; // Full name of the plugin (used for diagnostics)

For more information read Themes 2.0