Problems Installing Webwork on a New Server

Problems Installing Webwork on a New Server

by Mike Fisher -
Number of replies: 2
We're trying to set up a new server (we just got a new one and we haven't
updated Webwork in a VERY long time).

Here's the message I received from my more knowledgable colleague in
Computer Science who has been trying to help me:

"I have spent most of the day today trying to get an installation of
webwork on a virtual machine. No luck. I tried installations on both
Centos 7 and Ubuntu 16.04. Both get to a point where the web server should
restart, but it doesn't. It looks like something's wrong with the Perl
modules, but I cannot figure it out.

Unfortunately, there appears to be no "step-by-step" installation document
any longer. To do an installation, you need to run an installer script
which does all the work for you.

This installer script worked fine when I ran it last summer, but now it is
choking. I looked on the web and see other people have similar problems,
but not exactly the one I'm having, which I cannot solve."

Please help!

Thank you for you time.
In reply to Mike Fisher

Re: Problems Installing Webwork on a New Server

by Danny Glin -
It would be helpful if you could provide us with any errors that you get, either during the running of the installation script or when you try to start apache.

One gotcha on CentOS 7 when it comes to perl packages is described in this post.
In reply to Mike Fisher

Re: Problems Installing Webwork on a New Server

by Arnold Pizer -

If you want to use an install script, the one in master is out of date as you discovered. The one sitting in pull request 6 works but I have no idea if or when it will be put into master. If you want to use it, goto and look at the comments (near the bottom), specifically

I just tested this again on a brand new 16.04 installation and it worked perfectly. Specifically I used ubuntu-16.04.3-desktop-amd64.iso to create a virtualbox virtual machine. Then I ran the following commands (I'm writing them from memory, I did not copy them so there might be a typo below but I think not):
sudo apt-get install git
mkdir work
cd work
git clone git://
cd ww_install
git fetch origin pull/6/head:ww2.13
git checkout ww2.13
cd bin
sudo perl
Then open Firefox and goto localhost/webwork2