mpm_prefork and RAM

mpm_prefork and RAM

by Jason Cowell -
Number of replies: 1

Im sorry if this has been answered before

My system is 64GB RAM, and is completely dedicated to WW

my mpm_prefork file is like so

<IfModule mpm_prefork_module>
        StartServers             5
        MinSpareServers          64
        MaxSpareServers          128
        MaxRequestWorkers        256
        MaxConnectionsPerChild   100

I hammer the system by browsing and loading many problems from the Library browser, using many web browsers (on the same computer)

it fills right up the 64GB of RAM, and then does give some back eventually.

But should my settings be something different, so it doesn't max out right at 64GB ? it would be nice to have a little room

thanks so much for helping , I am new to WW

In reply to Jason Cowell

Re: mpm_prefork and RAM

by Nathan Wallach -

The library browser is a memory hog as it renders many problems in a single Apache worker. Gateway quizes also have similar issues.

You can reduce the memory it will use somewhat by:

  • lowering MaxSpareServers    (don't waste too much space on idle workers)
  • lowering MaxRequestWorkers    (do not allow to many to run, to avoid swapping and performance degredation)
  • lowering MaxConnectionsPerChild   (meant to kill workers before they get very large)

Adding in /etc/apache2/conf-enabled/webwork.conf (or wherever the real webwork.conf is on your system)

  # size limiter for Apache2 use Apache2::SizeLimit;
  $Apache2::SizeLimit::MAX_PROCESS_SIZE = 340000;
  $Apache2::SizeLimit::MAX_UNSHARED_SIZE = 340000;
  $Apache2::SizeLimit::CHECK_EVERY_N_REQUESTS = 5;

near the top of the <Perl> section. Search the forums for more about this.