LTI/Moodle problems

LTI/Moodle problems

by Suzanne Palmer -
Number of replies: 2

Hi all,

I have WeBWorK 2.15 installed on an Ubuntu 18.04 server and I'm trying to get it connected up to our college's Moodle instance. I went through all the steps (and double- and triple-checked) and it looks like Moodle is correctly talking to Webwork, but for the life of me I can't figure out how to get the student account creation working.

I have LTI enabled in /opt/webwork/webwork2/conf/localOverrides.conf:


In authen_LTI.conf I have:

$authen{user_module} = [
    {  "*" => "WeBWorK::Authen::LTIAdvanced", }, #preferred authorization method
    {  "*" => "WeBWorK::Authen::Basic_TheLastOption",}  #fallback authorization method
    #{  "*" => "WeBWorK::Authen::Moodle",}  #fallback authorization method

The webwork server does appear inside the Moodle frame as expected.

For the value of $external_auth, I have tried all three options, with the following results:

commented out, or 0: I get the WeBWorK login screen

1: I get the "MTH111_Moodle uses an external authentication system (e.g., Oncourse, CAS, Blackboard, Moodle, Canvas, etc.). Please return to system you used and try again." message.

I have set "$debug_lti_parameters = 1;" but there doesn't seem to be anything in there coming from moodle, just local logins by my administrators directly into the webwork server.

I feel like I've just missed something obvious, but I've been going over this again and again and just have no idea. Help?



In reply to Suzanne Palmer

Re: LTI/Moodle problems

by Nathan Wallach -
In Moodle - you need to make sure to open the Privacy settings for the LTI item and to mark at least the "Share launcher's name with the tool" item. I would recommend also marking "Share launcher's email with the tool".

In reply to Nathan Wallach

Re: LTI/Moodle problems

by Suzanne Palmer -
Thank you very much, Nathan! Couldn't have figured it out without your help.

The issue was that we didn't have the full path to the course in the moodle tool config, including the course name. So we were landing on the main page rather than the course page itself, which didn't give the authentication piece a chance to do its magic. Onward to the next challenge. (-: