WeBWorK Problems

WebWork2.16 Slow Load Times

WebWork2.16 Slow Load Times

by Kelsey Caron -
Number of replies: 4


I have A VM running Webwork 2.16. I installed it using the OVA image (https://webwork.maa.org/wiki/WeBWorK_2.16_Ubuntu_Server_20.04_LTS_Virtual_Machine_Image)

When I navigate to a course (and hit the login page) the page loads for a few minutes. While it is loading I notice the "continue" button is grey in style, and after the page loads it turns blue. 

In addition, after logging in and navigating to the "Library Browser", the page loads super slow, and the fields ('subject' , 'chapter' , 'section') slowly load one after another. (trying to pull the drop down menu for them before they load just show "all ____" until it fully loads.) When they are loading the drop down fields are very short, after they load the drop down menu stretches out to the normal length.

My system stats are as followed on the VM: 

CPU2 CPU(s), 25 MHz used
Memory4 GB, 0 GB memory active
Hard disk 1
20 GB | Thick Provision Lazy Zeroed

Has anyone ever had this problem? Is there a place I can check log files that would help trouble shoot if something is causing slow times. Do I need more physical resources pumped into my machine? 








Please help, 



In reply to Kelsey Caron

Re: WebWork2.16 Slow Load Times

by Kelsey Caron -
Just another note to my findings:

In the browser when I look at the network activity I see that one javascript file is timing out. The file is tex-chtml.js. I can find the file in the directory /opt/webwork/webwork2/htdocs/node_modules/mathjax/es5/tex-chtml.js

Looking at the network in developer console it has the path:

Not sure if this helps but it is something I now notice.
In reply to Kelsey Caron

Re: WebWork2.16 Slow Load Times

by Danny Glin -

Most likely this is a configuration issue and not a lack of resources.  Those specs should be sufficient to run a WeBWorK server.

This may be the same problem as in https://webwork.maa.org/moodle/mod/forum/discuss.php?d=5003#p16160.  Double check that you have replaced all instances of in localOverrides.conf with the IP address (or hostname) of your server.

Two places to check right away to see if they shed light on your issue:

  • The error console in your browser.  My suspicion is that you are experiencing a timeout when trying to load auxiliary files.  Your browser console will tell you this.
  • The apache error logs.  This will tell you if there are actual errors while WeBWorK is generating the pages, though it won't necessarily indicate if it is slow.
In reply to Danny Glin

Re: WebWork2.16 Slow Load Times

by Kelsey Caron -
I checked the localOverrides,conf file and the IP is correct everywhere that there is an IP. I do see a line that says:

$webworkURLs{MathJax} = 'http://XXX.X.XXX.XX:8080/webwork2_files/mathjax/es5/tex-chtml.js';

webwork2_files is not a directory or path. The path on my system that gets to tex-chtml.js is


Although when I try to change the line in my config file to match the placement of tex-chtml.js in my path it still doesn't work.

I tried changing it to:
$webworkURLs{MathJax} = 'http://XXX.X.XXX.XX:8080/webwork/webwork2/htdocs/node_modules/mathjax/es5/tex-chtml.js';


$webworkURLs{MathJax} = 'http://XXX.X.XXX.XX:8080/webwork2/htdocs/node_modules/mathjax/es5/tex-chtml.js';


$webworkURLs{MathJax} = 'http://XXX.X.XXX.XX:8080/htdocs/node_modules/mathjax/es5/tex-chtml.js';

but all of these changes didn't do anything. The console still shows that tex-chtml.js fails / times out with error:

 GET http://XXX.X.XXX.XX:8080/node_modules/mathjax/es5/tex-chtml.js net::ERR_CONNECTION_TIMED_OUT

(I found the above by looking at the console)