WeBWorK Problems

"This problem file was empty!"

"This problem file was empty!"

by Siman Wong -
Number of replies: 2
I just imported a new set of problems into our webwork 2.15 server.  When I clicked on each of the new problem sets,  (as far as I can tell) the problems are working, but I got the error message  "ERROR: This problem file was empty!" on the right margin.  I also go this same error message when I try to create a hardcopy. 

Here is the "Error details" shown on the right margin (note that it mentions "Problem 0" but there is no problem 0 in any of the set definition files):
Error messages
ERROR: This problem file was empty!

Error details

        Problem 0
2. ERROR caught by Translator while processing this problem
Request information
Time    Thu Jan 12 10:58:41 2023
Method    GET
URI    /webwork2/S23_MATH_300_03/1_1_Preliminaries-Logic_Introduction/
HTTP Headers   
Cookie    WeBWorKCourseAuthen.S23_MATH_300_03=SimanWong%09Ub884FKbeT1tT8FimTnqLp8puTXF2dAf%091673539029
Host    webwork2.math.umass.edu
Sec-Fetch-User    ?1
Upgrade-Insecure-Requests    1
dnt    1
User-Agent    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
Referer    https://webwork2.math.umass.edu/webwork2/S23_MATH_300_03/hardcopy/1_1_Preliminaries-Logic_Introduction/
sec-gpc    1
Accept-Language    en-US,en;q=0.9
Sec-Fetch-Mode    navigate
Sec-Fetch-Site    same-origin
Connection    keep-alive
Accept    text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9
sec-ch-ua    "Not_A Brand";v="99", "Google Chrome";v="109", "Chromium";v="109"
sec-ch-ua-mobile    ?0
Accept-Encoding    gzip, deflate, br
Sec-Fetch-Dest    document
sec-ch-ua-platform    "Linux"
WeBWorK Warnings
WeBWorK has encountered warnings while processing your request. If this occured when viewing a problem, it was likely caused by an error or ambiguity in that problem. Otherwise, it may indicate a problem with the WeBWorK system itself. If you are a student, report these warnings to your professor to have them corrected. If you are a professor, please consult the warning output below for more information.

Warning messages
ERRORS in rendering problem: 0 |setHeader.pg| ERROR: This problem file was empty!
Request information
Time    Thu Jan 12 10:58:41 2023
Method    GET
URI    /webwork2/S23_MATH_300_03/1_1_Preliminaries-Logic_Introduction/
(1) The warning message above also appears when I tried to create a hardcopy.

(2) I encounter these errors only with the newly imported problems.  I created a new problem set using existing problems from the OPL and I do not see these errors.

Any suggestions on how diagnose and fix this problem is most appreciated.  THANKS!

In reply to Siman Wong

Re: "This problem file was empty!"

by Danny Glin -

The warning message tells you which file is empty, namely setHeader.pg.  Most likely your set definition file named a header file to be used with that set, and that header file is not present in your new course.

You should either copy the header file into the course, or change the set to use the default header file.

In reply to Danny Glin

Re: "This problem file was empty!"

by Siman Wong -
The sets I uploaded turns out to default to "setHeader.pg" and "setHeader_paper.pg", while our 2.15 server has "ASimpleHeader.gp" and "ASimpleHardCopyHeader.gp". I made a copy of our two header files, renamed them to the ones used in the sets, and everything works now.

Thanks so much!