WeBWorK Main Forum

Error when trying to open the Homework Set Editor

Error when trying to open the Homework Set Editor

by Murphy Waggoner -
Number of replies: 8
I get the following error when I try to open the Homework Sets Editor in one of my courses, but not the others.

I can open a specific Homework Set to edit it by selecting it in the Homework Sets menu and then clicking on it under the Homework Sets Editor link. So this isn't keeping me from working on the course, but it is cumbersome.

Thoughts? Other information I need to provide?


Sat Aug 25 19:59:06 2018

Warning messages

Error messages

/opt/webwork/libraries/webwork-open-problem-library/Contrib/Contrib is a recursive symbolic link at /usr/share/perl/5.22/File/Find.pm line 88.

Call stack

The information below can help locate the source of the problem.

  • in File::Find::Follow_SymLink called at line 637 of /usr/share/perl/5.22/File/Find.pm
  • in File::Find::_find_dir_symlnk called at line 223 of /usr/share/perl/5.22/File/Find.pm
  • in File::Find::_find_opt called at line 759 of /usr/share/perl/5.22/File/Find.pm
  • in File::Find::find called at line 700 of /opt/webwork/webwork2/lib/WeBWorK/ContentGenerator/Instructor.pm
  • in WeBWorK::ContentGenerator::Instructor::getDefList called at line 1307 of /opt/webwork/webwork2/lib/WeBWorK/ContentGenerator/Instructor/ProblemSetList2.pm
  • in WeBWorK::ContentGenerator::Instructor::ProblemSetList2::import_form called at line 593 of /opt/webwork/webwork2/lib/WeBWorK/ContentGenerator/Instructor/ProblemSetList2.pm
  • in WeBWorK::ContentGenerator::Instructor::ProblemSetList2::body called at line 155 of /opt/webwork/webwork2/lib/WeBWorK/Template.pm
  • in WeBWorK::Template::template called at line 560 of /opt/webwork/webwork2/lib/WeBWorK/ContentGenerator.pm
  • in WeBWorK::ContentGenerator::content called at line 232 of /opt/webwork/webwork2/lib/WeBWorK/ContentGenerator.pm
  • in WeBWorK::ContentGenerator::go called at line 384 of /opt/webwork/webwork2/lib/WeBWorK.pm

Request information

Method GET
URI /webwork2/Waggoner-Math-208-Fall-2018/instructor/sets2/
HTTP Headers
Referer https://math.simpson.edu/webwork2/Waggoner-Math-208-Fall-2018/instructor/sets2/Statistics_foundations/
Accept text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8
Cookie WeBWorKCourseAuthen.Sweet-Math-251-Fall-2018=murphy.waggoner%09HMjSnXXMn8cJGl4QnbiluCBmJueAuGCg%091535233680; WeBWorKCourseAuthen.Sweet-Math-251A-Fall-2018=murphy.waggoner%099SjRgpgwwCT9L4dS3yIomrVLDXiHukoc%091535233711; WeBWorKCourseAuthen.Waggoner-Math-255-Fall-2018=murphy.waggoner%09SfUO4MihbYJVOupCGgoVVuGNKDiYh3rJ%091535244788; WeBWorKCourseAuthen.Waggoner-Math-360-Fall-2018=murphy.waggoner%09peigHpmBLmiOnDlvG0AjpzyOY6vcwDRV%091535244803; WeBWorKCourseAuthen.Waggoner-Math-152-Fall-2018=murphy.waggoner%09eZQE7hAwIW6zJryrp0E0cwZaItpOzbmZ%091535244816; WeBWorKCourseAuthen.admin=murphy.waggoner%09ZQlluZHe2mr4vl2xow302fNwvZm1YbHy%091535244978; WeBWorKCourseAuthen.Waggoner-Math-208-Fall-2018=murphy.waggoner%093zZO3wEFVWz06j0HAubc1RemGWAJT4fp%091535245144; _ga=GA1.2.1259058044.1525121232; __auc=16675280163184f2d3f65dddd8c; AMCV_774C31DD5342CAF40A490D44%40AdobeOrg=793872103%7CMCIDTS%7C17659%7CMCMID%7C35101904255124546128656154365794947125%7CMCAID%7CNONE%7CMCAAMLH-1526341135%7C7%7CMCAAMB-1526341135%7Cj8Odv6LonN4r3an7LhD3WZrU1bUpAkFkkiY1ncBR96t2PTI; s_fid=22AFC406A984BB14-054D51C63E851E3B; _gid=GA1.2.1986277522.1535187196; lmdatab7fe945098343305ca7a826c7814fab0=2dd1a40b70e1b86d7792d3e6042acd8f
Accept-Encoding gzip, deflate, br
Upgrade-Insecure-Requests 1
Connection keep-alive
User-Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36
Host math.simpson.edu
Accept-Language en-US,en;q=0.9,es-419;q=0.8,es;q=0.7
In reply to Murphy Waggoner

Re: Error when trying to open the Homework Set Editor

by Michael Gage -
You have a misplaced symlink in your library directory which is causing a circular reference. If you
use the command line to step through the webwork-open-library-problems/Contrib directory you'll find an alias that points back to its parent.

My guess is that there is an entry Contrib/Contrib and that

ls -l Contrib/Contrib ==> Contrib

Some of the scripts that automatically update the Library aliases can cause this to happen. That's a fairly easy bug to fix if anyone is interested. The bug is also only a minor annoyance which is why it hasn't been fixed already.

-- Mike
In reply to Michael Gage

Re: Error when trying to open the Homework Set Editor

by Murphy Waggoner -
I sent your recommendation to our ITS office and they must have done this because I stopped having problems.

However, today I tried to use Library Browser to get into the Contrib library to look for some problems from UBC. The Library Browser page never loaded. I closed out of Chrome and got back in. Tried several times, but no success.

So instead I went directly to the Homework Sets Editor to paste the raw code for a problem directly into the editor. But I got the error above again.

Does this mean I ran into one of those scripts you mention again? For this user it is not a minor inconvenience as I can't access the Homework Sets Editor page directly and have to edit problems one by one. It is not until the ITS office opens again on Monday that I can get someone to execute the command you gave above (as I don't have access to the server and ITS won't give access to our department).

On a related note, it also means I can't use the Library Browser to get to problems in the Contrib library. Drat.

Thanks for any guidance on this.
In reply to Murphy Waggoner

Re: Error when trying to open the Homework Set Editor

by Michael Gage -
It's likely a self-referential link causing an infinite loop. We try to catch those infinite loops but apparently we're missing one. If you can get the systems guys to report back what was wrong this time we'll see what we can do to make the error reporting better.

The self reference might only be hit when you are looking in specific directories. Different courses would have different problems assigned
(or even different homework sets would have different problems). This could be used to trouble shoot in which directory the self-reference is occurring. This is just a guess. It would be easiest to diagnose this if I had access both the course on the web and a view of the apache error log on the server. Perhaps your IT guys are willing to work together with you on this?

In reply to Michael Gage

Re: Error when trying to open the Homework Set Editor

by Murphy Waggoner -
One more thing: Why does this affect only one of my classes and not all?
In reply to Murphy Waggoner

Re: Error when trying to open the Homework Set Editor

by Erick Tayouo -
I have the same problem. When remove the symbolic link, this error disappear, but it's not my ideal solution.

In fact, this problem occurs when we add a new library. I use Webwork 2.13 for example in my case, I added a library called "Banque de problème", I created a symbolic link "BPL" to this folder in /opt/webwork/courses/Test-BPL/templates/ and I updated the following file :
$ sudo nano /opt/webwork/webwork2/conf/localOverrides.conf

$courseFiles{problibs}  = {

 Library => "NPL Directory",

 BPL => "Banque de problèmes",

 # rochesterLibrary => "Rochester",

I am guess for this problem, something would change in code, bbut I dont't know what.

In reply to Erick Tayouo

Re: Error when trying to open the Homework Set Editor

by Erick Tayouo -
I forgot to paste her my problem, it's similar

Attachment Webwork.png
In reply to Erick Tayouo

Re: Error when trying to open the Homework Set Editor

by Erick Tayouo -
My solution:
# Make sure that your directory library have the good permission
wwadmin@WEBWORKTEST:/opt/webwork/libraries$ ls -la
total 16
drwxr-xr-x 4 wwadmin wwadmin 4096 oct 1 10:25 .
drwxr-xr-x 8 wwadmin wwadmin 4096 sep 25 15:17 ..
drwxr-xr-x 5 root root 4096 oct 1 10:25 webwork-banque-problemes-libres
drwxr-xr-x 6 wwadmin wwadmin 4096 aoû 6 15:24 webwork-open-problem-library
wwadmin@WEBWORKTEST:/opt/webwork/libraries$ sudo chown -R wwadmin webwork-banque-problemes-libres/
wwadmin@WEBWORKTEST:/opt/webwork/libraries$ chgrp -R wwadmin webwork-banque-problemes-libres/

# I noticed that there was a junk link added in directory /opt/webwork/libraries/webwork-banque-problemes-libres/BPL. this link creates a loop with the link I created in /opt/webwork/courses/Test-BPL/templates
wwadmin@WEBWORKTEST:/opt/webwork/libraries/webwork-banque-problemes-libres/BPL$ ls -la
total 20
drwxr-xr-x 5 wwadmin wwadmin 4096 oct 1 10:51 .
drwxr-xr-x 5 wwadmin wwadmin 4096 oct 1 10:25 ..
drwxr-xr-x 13 wwadmin wwadmin 4096 oct 1 10:25 BdeB
lrwxrwxrwx 1 wwadmin wwadmin 59 oct 1 10:51 BPL -> /opt/webwork/libraries/webwork-banque-problemes-libres/BPL/
drwxr-xr-x 22 wwadmin wwadmin 4096 oct 1 10:25 CCDMD
drwxr-xr-x 29 wwadmin wwadmin 4096 oct 1 10:25 Mathema-TIC
wwadmin@WEBWORKTEST:/opt/webwork/libraries/webwork-banque-problemes-libres/BPL$ sudo rm BPL

After this, all work for me.
In reply to Erick Tayouo

Re: Error when trying to open the Homework Set Editor

by Michael Gage -
Hi Erick,

That junk link which references itself was causing the problem.

There are a couple of automatic scripts (e.g. updating the Library link)
that sometimes create these spurious links. Fortunately these
scripts don't need to be run very often and it is relatively easy to
clean up after them if you recognize what is causing the trouble.

Take care,