Installation Problem -- Piink Screen

Installation Problem -- Piink Screen

by Wojciech Komornicki -
Number of replies: 2
When I choose the images display option, which I understand as generation of images via dvipng, I get the pink screen of which I am warned in the installation. I have tried the solution proposed in the installation directions, running
fmtutil --missing
but this does not help. The permissions seem to be correct since the timestamp on the tmp directory (/opt/webwork/webwork2/tmp) is being updated.

Can I debug the process in some way, say, by running the script by hand? Just for completeness, the error(warning) message I get is

cd /opt/webwork/webwork2/tmp/ImageGenerator.h7a4x67o && /usr/bin/latex equation > latex.out 2> latex.err failed to generate a DVI file at /opt/webwork/pg/lib/WeBWorK/PG/ line 358.
cd /opt/webwork/webwork2/tmp/ImageGenerator.h7a4x67o && /usr/bin/dvipng -bgtransparent -D120 -q -depth equation > dvipng.out 2> dvipng.err returned non-zero status 256: No such file or directory at /opt/webwork/pg/lib/WeBWorK/PG/ line 364.
In reply to Wojciech Komornicki

Re: Installation Problem -- Piink Screen

by Michael Gage -
Check to make sure preview.sty is present in the tex paths:

also read this

and if that hasn't worked read down the entire thread under:
In reply to Michael Gage

Re: Installation Problem -- Piink Screen -- Solved

by Wojciech Komornicki -
I do not know which of the actions solved my problem but here is what I did
1) I updated installed Fedora Packages
2) Installed KDE Desktop (though I usually use GNOME)
3) Rebooted the machine

Now images does not cause a problem.